I would like to edit a video, but as I import it into AfterEffects it does not show the correct colors. VLC does show the correct colors. It's not the codec, because h264 is supported by aftereffects. It is not the edit lists. The imported video looks like this.incorrect colored video

I suspect alpha has somethin to do with it, because if I decativate alpha (ALT + 4) the screen becomes white.

After rendering it still looks like this.

I'm at a loss where to look for the cause, please give me some hints where this is coming from and/or how to get rid of it.

  • 2
    That looks like corruption in the file. The screen going white when you hit ALT-4 is not because it's deactivating alpha, it's showing you the alpha channel - and as the whole frame is solid the alpha channel is pure white.
    – stib
    Commented Mar 5, 2019 at 6:44

2 Answers 2


I'd recommend trying to convert the source file to another file type before importing into After Effects. Maybe try the media encoder, vlc or an ffmpeg variant. If you can, convert to an intermediate mov-codec or an image sequence like tiff. If your file seems fine in VLC etc. this might work.


For me it was solved by going to file->project settings->Video Rendering and Effects(tab) then selecting mercury software only and saving it.

After re-importing the video file, color was normal.

Youtube video:

after effect setting image

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.