I am new to After Effects and I have the following problem with an animation of mine:

I have a walk cycle drawn for 8 frames per second. The composition has 24 frames per second, so each frame of the animation is shown for three frames. The background moves using keyframe animation.

But now the background moves every frame whereas the animation only moves every third frame, which looks odd as the feet seem to slip. If I change the frame rate to 8fps, it looks fine.

So is it somehow possible to change the movement of the background so that the position is only updated every third frame?

I would like to avoid changing the frame rate of the whole composition to 8fps, as then other parts of the animation become less smooth.

1 Answer 1


I don't know if there is an easy way to do it directly. You could do some modular math in a script for the keyframe positions, but that's kind of complicated and non-user friendly. An alternate approach would be to do an additional nested composition.

Make an animation composition for your character that is at 8 FPS, perhaps bring in the main composition as a backplate while putting it together, then remove the backplate and import the animation composition at 24fps as a stationary composition.

  • I already tried your second approach. But unfortunately the composition (or at least the animated properties) become 24fps as soon as they are imported into a 24fps composition. Although I am not sure, what a 'stationary' composition is, exactly.
    – sietschie
    Oct 6, 2013 at 16:12
  • But since I am from a programming background I found you first idea quite appealing and was able apply it to my problem. I used the following expression: transform.position = position.valueAtTime(Math.ceil(-2/3 + time*8)/8)
    – sietschie
    Oct 6, 2013 at 16:14
  • @sietschie - I just meant that you include the composition as a nested composition and don't animate it any. Interesting that it automatically updated the frame rate within when you tried that. I think there might be a setting to prevent that, but I don't recall exactly. (I don't have to deal with the mismatch problem often.) Glad the scripting worked for you though.
    – AJ Henderson
    Oct 6, 2013 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.