1

I've been using after effects cs6 to make intros in my youtube template. They always render without sound. I've been exporting them as avi files. I'm currently making one in an mpeg4 format (assuming that is another name for mp4) since my other intros all have sound and they're mp4 files.

I clicked "lossless" in the render queue and I changed the file format to avi. I checked "audio output" and didn't touch the settings inside that submenu and then I clicked OK and render. after waiting a while, AE spit out an intro file thats around a gigabyte in size and has no sound. What is the problem?

4
  • Are you sure you have an active audio track in your timeline? Aug 13 '15 at 2:42
  • possible duplicate of AE - Composition video file/layer missing audio ?
    – p2or
    Aug 13 '15 at 11:26
  • @NateBarbettini here's a picture of the layers. I am unsure if there are hidden layers or whatever Aug 15 '15 at 2:52
  • 2
    @RegisteredUser And where is your audio layer in the composition? As you can see, in this composition is no audio, if a layer consists of audio the audio Icon (right beside the visibility icon) will appear. Could you please add a more meaningful screenshot? What about the answers in the linked question?
    – p2or
    Aug 15 '15 at 8:22
1

The output file doesn't have any sound because there is no audio in the timeline that you are rendering.

The output format (MP4 vs. AVI) doesn't have any effect; both formats can contain an audio track or not. Checking the box to output audio only has any effect if there is already an audio track in the timeline. If there's no audio track, the output will have audio but it will be silent (as you're experiencing).

The solution is to add some audio file(s) to the project and then put it into your timeline.

0

The MPEG4 has no audio settings. I chose h.264 and now I can see the Audio settings. So basically this MPEG4 has not audio output at all. That's why no audio is in the rendered video. This is very strange.

A lot of people out there are wondering why this is happening. Well its part.y our fault. We should notice there is no Audio settings in this format. I think AE should specify that this MPEG4 version is Video only. So all other option works I guess if you see an Audio setting with the option to choose format and bitrate then it will include the audio.

Yes all rendered and I can hear the audio perfectly 1:12 second video at 127 MB excellent quality at 300 Bitrate (maximum is 300 in this format) so have to play with it a little and see how far I can reduce the size.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.