We have a number of meeting rooms that were equipped with an AV cabinet and projector each. There's a local PC and input for mobile devces at the meeting table. All of the cable runs are HDMI (those longer than ~10m are supported by active Kramer Cat6 Baluns). We've standardised on 1080p for our displays. Locally, everything works well.

We've upgraded two of these rooms for conferencing. This includes: A second, wall mounted TV and a LifeSize Express 220. Input are handled by a Kramer VS-84 (or VS-44) matrix switcher, such that the image to the Projector is mirrored to the DVI-I Input of the LifeSize unit, making it possible to present to remote participants from any of the input devices with ease.

Now, the LifeSize 220 series doesn't support 1080p input for presentations. This wasn't regarded as a significant issue, since a compressed, downscaled input was judged sufficient for passive observers.

To rectify this, we installed a Kramer VP-424 scaler in-line between the switch and the LifeSize. (HDMI in and out). This would give us a clean 720p feed to the LifeSize while all the local displays stay at 1080p.

Here's where the problems come in: At both sites, output from the scaler was being corrupted or not displayed. The pattern of this varied depending on the input device and the scaler used:

  • Kramer VP-424: Macbooks and iOS devices Display, but are subject to very regular (1/s) single-frame flashes of noise with audible popping sound. Windows laptops display cleanly
  • CYP SY298H: Similar to the Kramer, with audible poppping, but the image would drop to flat blue and 'No Input', or appear squashed up into the top 1/6 of the screen.
  • Extron DCS 301: A clean display from Windows laptops, but a no output whatsoever from any Apple devices.

We've also tried:

  • Many (many) cables.
  • Direct device input to the Lifesize (Everything works, as the device will downscale to 720p on connection, but it requires manual connection wrangling prior to meetings, which isn't sustainable)
  • Discussing with our installer. (They're being brilliant about this, but they're as stumped as we are)
  • Discussing with LifeSize support (Also very helpful, but there are too many variables and 3rd party products for them to suggest anything concrete)
  • Not having the scaler: All inputs are corrupted as the switch tries to feed 1080p into the LifeSize.

We can't enforce input device type, as support for everything is required in our environment. We can't really mandate 720p across the board as, although it's sufficient for passive viewing, the presenter still needs 1080p (lots of small text and Wireframe 3D in some cases).

I'd love a one-shot solution to this, but if anyone can give me some pointers in how to further debug the problem, I'll be in their debt. (I can provide diagrams of the setup, if it'll help)


At AJ's Suggestion, I removed the switch from the equation. (Mackbook 1080p@60 -> Scaler-> Lifesize). To start with, the issue was just as apparent. Then I tried something we'd eliminated previously, and switched off the HDCP on Input option. Suddenly I'm looking at a clean, scaled 720p image!

So I put the switch back in line and now all I see is what we saw with earlier tests: A blank screen. Still, this means that without the switch in place, HDCP isn't needed. If I can disable it in the entire chain, then we might be sorted. I'll report back when I've done some further testing.


Something I didn't point out previously: If I take the codec out of the equation (Mac -> Scaler -> TV), then I don’t see any problems at all, regardless of the HDCP setting.

So we have HDCP being agreed from device to switch to (if it's enabled) scaler. It looks like the scaler -> Lifesize negotiation is where it's failing. Both agree on HDCP support, but then something goes wrong that causes this regular popping.

  • 1
    Posting as a comment since this is more of a guess than an answer, but it sounds like something is going wrong with negotiating the signal between the matrix switch and the scaler, possibly because the input switch is negotiating with the TV and input as well. Does it work correctly with the scaler without the switch (or with the TV removed from the system)?
    – AJ Henderson
    Nov 27, 2013 at 19:21
  • Not a combination I'd tried before, so I gave it a go (See edit) Nov 28, 2013 at 15:42
  • ok, that actually kind of confirms my suspicion but I don't know enough about the particular hardware you are using and HDCP to figure out what exactly it is. It is certainly negotiation related though since turning off part of the negotiation (the content protection part) made it start working for you. From what I recall, switches and HDCP tend to not get along well because the two displays conflict with each other on the negotiation. I'd ask the switch manufacturer about it probably because I think the ball is in their court.
    – AJ Henderson
    Nov 28, 2013 at 16:54
  • According to Lifesize, there's no HDCP support at all, so it's odd that we're getting any input at all while it's enabled. I think my only option is to disable HDCP support at the switch (if possible) so that opportunistic devices (like Macs/iOS) don't bother with it. I'll leave this question up and follow up if I make any progress in that direction. Nov 28, 2013 at 19:15

1 Answer 1


I've found an answer to my specific problem that's a little ugly, but might be of some use.

The basic premise is to ensure that the first device in the chain does not support (or is capable of disabling support for) HDCP. Macs and iOS devices are opportunistic when it comes to HDCP; they'll always attempt to negotiate it, but will fall back to unencrypted when there's no protected content playing.

The Kramer VP-424 scaler has a setting "HDCP on input" that will, when disabled, prevent that negotiation. By putting one of these inline between the input and the switch, HDCP never starts and the whole chain is unencrypted:

Mac -> VP-424 (HDCP Disabled, 1080p output) ->VS-84H Switch -> VP-424 (HDCP Disabled, 720 Output) -> LifeSize Codec.

The scaling doesn't have any noticeable effect on image quality or unduly effect sync times, which is a bonus. I still get 1080p out to the local projector and downscaled 720p to the codec.

As I say, it's neither pretty, nor cheap; but it works.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.