0

Is there a way to use ffmpeg (or anything else that can be used in linux) to fix an interlaced video marked as progressive, and mark it as interlaced so that I can get rid of bad interlaced frames?

Here's an example of how it is: Hardly interlaced frame

And how it should be: Not interlaced

Here's the mediainfo of the video:

Video Format : MPEG Video Format version : Version 2 Format profile : Main@Main Format settings, BVOP : Yes Format settings, Matrix : Custom Format settings, GOP : Variable Bit rate mode : Variable Maximum bit rate : 9 800 kb/s Width : 720 pixels Height : 480 pixels Display aspect ratio : 4:3 Frame rate : 23.976 (24000/1001) FPS Standard : Component Color space : YUV Chroma subsampling : 4:2:0 Bit depth : 8 bits Scan type : Progressive Scan order : 2:3 Pulldown Compression mode : Lossy Time code of first frame : 01:00:05:00 GOP, Open/Closed : Open GOP, Open/Closed of first frame : Closed Color primaries : BT.601 NTSC Transfer characteristics : BT.601 Matrix coefficients : BT.601

Do I need a reencode to fix this? Or just change its wrong flag?

3
  • How do you plan to fix it?
    – Gyan
    Apr 18, 2019 at 5:03
  • @Gyan I don't know how to fix it. I just have a possible diagnosis. Some forums say the problem lies on the 'progressive' flag. How do I change the flag, then? Do I need to inverse telecine it or something? If so, how do I do it? I couldn't find any solution that actually work anywhere I have searched in. That's why I am asking how to fix it. I tried reencoding it with the -ilme option and it just made it worse. Apr 18, 2019 at 21:30
  • Did you ever get around this problem? I'd like to know too if there is some way to fix incorrectly marked 'progressive' frames to interlaced without re-encoding.
    – hedgehog90
    Aug 30, 2020 at 11:06

1 Answer 1

1

Sorry for the late reply. For anyone wondering, the video actually is progressive. The next line in the mediainfo shows 2:3 pulldown, which is a software added telecine (soft telecine). You can also see the framerate is 23.976 fps, which should never indicate interlaced video. This means each frame is progressive, and the video file has flags on the frames so the video player can add telecine during playback so the video is 29.97 fps. I believe VLC media player ignore the flags completely these days and only shows the progressive frames. You can also use AVISynth to do an inverse telecine with the plugin TIVTC, I suggest making a d2v file with DGIndex from DGMPGDec, but it will be a reencode. There might also be a way to remove the 2:3 pulldown flag in the metadata, which would remove the telecine without reencoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.