I am trying to convert an HDMI video signal (from my computer's graphic card) to SDI using an Ultrastudio 3D from Blackmagic.

I successfully converted an HDMI signal from my Canon 5D camera, but it does not work when I send a signal from my graphics card.

What is the difference between HDMI from a camera and HDMI from my GPU?


My goal is to send GPU generated content, not a film, so there should be no HDCP problems, am I right? So far I tried to sent my GPU output considering the Ultrastudio 3D as an extended desktop.

  • Assuming frame rate and size are the same, it's possible that the GPU output is encapsulated in HDCP, where the camera's is not. Did you try using a Bluray player playing copyrighted content as the source? That would have HDCP for sure.
    – Jim Mack
    Commented Jul 1, 2014 at 23:17
  • Thanks for the tip, I will try this! I heard that this might be due to HDCP, but I had no clue how to test it.
    – arthur.sw
    Commented Jul 2, 2014 at 7:58
  • Now, is there any graphics card without HDCP on the market? Mine is a Geforce GTX 770.
    – arthur.sw
    Commented Jul 2, 2014 at 7:59
  • I don't believe there are GFX cards without HCDP. I suspect they all use a combo HDMI/HDCP chip for output.
    – Jim Mack
    Commented Jul 2, 2014 at 11:38
  • So there is no solution for my problem? I have seen this kind of things but I am septic, especially since I need 3D HDMI...
    – arthur.sw
    Commented Jul 2, 2014 at 12:23

1 Answer 1


What solved the problem:

Check your capture software settings. All settings (your monitor/capture device settings, your hardware settings and the settings in your capture software) should be correct and equal.

What can help track down similar issues:

Very likely a framerate issue. Only the 4K version of the Blackmagic Capture cards supports 60FPS and your monitor is or was probably set to 60Hz or 50Hz, though your capture card probably is only supporting 30FPS @ 1080p (assuming thats your resolution). (Edit: In this case not true, the UltraStudio (4k) does support 60fps even at 4k over SDI but if someone else has this issue, have a look at the specs of your capture card)

Assuming your are using Windows go to the resolution settings and click on advanced settings after selecting the capture card "display" and then go to the "Monitor" tab and select a lower refresh rate like 30FPS or 25FPS. Then set the same refresh rate in your capture settings.

On a Mac you can use a tool called SwitchResX to change your refreshrate or alternatively in your case simply set your capture settings to the output settings shown in the System Informations for the Capture Card "display". So same resolution and refresh rate.

If your really unlucky your Mac doesn't recognize the UltraStudio as a display or the Ultrastudio isn't sending any EDID information, though I somewhat doubt that's the case. I had this issue all the time with the 4K PCI-E capture card from Blackmagic, it always was a settings mismatch.

Also make sure that if you want to capture a video that's playing back, it isn't protected by HDCP like Jim Mack suggested.

  • I am under os X, I will try something like that, but I think that the Ultrastudio 3D supports 60fps...
    – arthur.sw
    Commented Jul 2, 2014 at 8:05
  • Indeed, I didn't know they had this product, its the equvivalent of their PCI-E card that I was talking about, so it's not a support issue. Still the frame rate that your GPU is outputting is probably not the same as you capture settings. I get that all the time when capturing my GPU output, the GPU detects some weird refresh rates like 29,97 or 30i and I always have to manually set it to my desired capture frame rate. Only when the driver settings of your BlackMagic Capture device and the output of your GPU are the same you are able to capture.
    – timonsku
    Commented Jul 2, 2014 at 14:08
  • I edited the answer with some Mac specific information.
    – timonsku
    Commented Jul 2, 2014 at 14:17
  • In "system preferences > monitor" my Ultrastudio 3D is recognized as a screen, with decent presets. I can set its resolution and framerate to whatever I want. But nothing seems to be working. I always have a black screen. Do you also have a blackscreen when the problem comes from the framerate?
    – arthur.sw
    Commented Jul 2, 2014 at 14:57
  • Yes that means the BlackMagic is simply ignoring the input. Are you sure you are capturing with the exact same settings on both ends? Differing resolutions will result in the same issue. Also if you are capturing over a Displayport adapter ditch that and try to capture over HDMI or DVI->HDMI. I always had issues using a DisplayPort->HDMI adapter. Also maybe try a different cable if you have one at your hand. I had issues with some otherwise working HDMI cables for unkown reasons.
    – timonsku
    Commented Jul 2, 2014 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.