1

Input and output video formats are from the same generation (similar quality for similar bitrate). Handbrake default settings are prioritizing smaller size over better quality. Video bitrate is divided by 10, which is seriously impacting quality. Not so much because input is strongly standardized (Blu-ray) and Blu-ray tools are not optimized, but 2.5 Mbps is ...


1

One thing you can certainly do is lower the bitrate. 23 is quite a high bitrate, even more so for a h.264 .mp4. You should get away with a bitrate of 5-7. Also, you're encoding using the preset of 720p, which would be 1280×720 pixels. However, you stated that your resolution is only 640x480, so matching those settings will do a great deal in filesize aswell.


Only top voted, non community-wiki answers of a minimum length are eligible