5

Production codecs with alpha channel support Apple ProRes 4444 / Apple ProRes 4444 XQ From the Manual: Apple ProRes 4444 and Apple ProRes 4444 XQ are ideal for the exchange of motion graphics media because they are virtually lossless. They are also the only Apple ProRes codecs that support alpha channels. DNxHD From Wikipedia: lossy high-...


4

The encoder is always the same, namely Adobe Media Encoder. What you're changing is only the format, which admittedly is a bit confusing since that dropdown mixes up a couple of concepts which don't really belong together. If you select H.264 from the format dropdown, that's the video codec. Using that format selection, you will find a ton of options below, ...


4

File > Add to Render Queue > Output mode > Format 'Quicktime' / Channels 'RGB + Alpha' See if that works for you!


4

Adobe licenses its H.264 encoder from Mainconcept, which doesn't do that well at low bitrates. x264 is pretty much the frontier when it comes at low size output for a given quality target, or quality for a given bitrate target. x264 is what's used by platforms like Youtube / Vimeo ..etc to encode user videos. One thing you could try is to increase the ...


3

Yes, for the Quicktime output module, choose to output RGB + Alpha using PNG or Animation codec. In Media Encoder, choose Depth as 32 Bit after selecting the same codecs as above.


3

Tell your friend that good software costs money. And is made by developers who need to put food on the table.


3

Click the output mode in the render queue, by default it says lossless: use these settings, format: quicktime, video output channels: RGB + Alpha: click format options and choose Apple ProRes 4444. The 4th 4 is the indicator that the codec has an alpha channel (this only applies to the Apple ProRes codec naming scheme). That should fix your problem. Edit:...


2

As answered in this Q/A, the problem looks to be caused by the use of the CUDA renderer ("Mercury"). The solution is to switch to CPU-only rendering.


2

The definition of "29.97" is correctly 30 * (1000 / 1001), which is 29.97002997. That's what you have. I don't know why do you think you need exactly 29.97000, but it's probably a misunderstanding.


2

Make sure that only the comps you want rendered are in the top level of the project. If there are compositions that you don't want rendered, such as subcomps, put them in a folder in your project window


2

Media Encoder and ffmpeg should generate the same quality if given the same encoding parameters. GPU encoders are provided by GPU vendors. I haven't heard of any third-party implementations. The possible differences lie in the wrappers i.e. the code which initializes the encoder parameters, and written by the interfacing app. There, I would expect ffmpeg to ...


2

You can not. You have contradicting parameters. You need to make some decisions. Either: Leave your project at 29.97 and drop 1 every 2 frames of your 60fps clip. Leave your project at 29.97 and use all the frames of the 60 fps clip making it slow-motion 2x. Change the project speed to 60fps and render twice every frame of the other footage. Change the ...


2

Are you exporting to h.264? Try rendering to a master file in a intermediate codec like ProRes, Cineform or DNxHR. Rendering to h.264 involves referencing multiple frames to create the intermediate frames. When those frames have to be rendered first it adds an extra drain on resources, particularly memory. Is the computer hitting the limits of available ...


2

I avoid AME and use x264 via ffmpeg for H.264 encoding. From Premiere I prefer to output a temporary lossless compressed format as the intermediate, such as the free and open-source Ut video, instead of DNxHD/DNxHR/ProRes. This avoids any generation loss (minor as it may be with ProRes/DNxHD, but still technically present as they are not lossless). Also, I'm ...


2

Check your GPU settings in AME prefs should be targeting your particular GPU. Choice of GPU can effect render time significantly. A GPU with a high CUDA processor count is best for these renders on a PC. On a MAC it should be metal with an appropriate card. Try and get a view of your system performance and buy a better card. https://www.cgdirector.com/best-...


1

No there isn't. You could nest each section from your master timeline into it's own timeline, from the in and out points of where your start marker to your next would be. That is the only thing I could think of. You could still work off the master timeline provided you dont do any time shifts / move any content up or down the timeline. Then you could ...


1

when you are exporting you should be able to change the frame rate in the basic video setting. If you "un-check" the box of the preset option, you can select the rate between different values.


1

The choice of codec will largely depend on what you're doing with the material. Your problem is that there just aren't enough colours in 8-bit colour space to give you a smooth gradient over the size of the frame. Problem is that if you want to deliver it on the internet you're pretty much locked in to h.264 (or I guess webm or ogv, but same deal). You can ...


1

I can't see your images for some reason but I suppose this is intentionally added in the template project. To remove it you would of course need to figure out which effect within AE is creating this problem, which I can not do without looking at the file... however I would look for effects like "Optics Compensation" or "Transform" (the effect, not the ...


1

Renaming the files to .m2ts seemed to have solved the issue.


1

Are you using OBS Studio? If yes, you should try OBS built-in convertor to mp4. Use File->Convert Recording.


1

Yes it is. Otherwise you wouldn't be able to encode things, and that would be just dumb. Even though it happens a bit under the hood, all encodings from Premiere Pro and After Effects are handled by Media Encoder. When you install Premiere Pro or After Effects, Media Encoder always gets installed alongside it.


1

With Mulvya's help, I figured out the issue. FFMPEG was using a codec tag of hev1, while Media Encoder was using hvc1. Nothing I tried in FFMPEG would change this. Mulvya suggested I use mp4box to repackage. mp4box -add out.mp4 -new final.mp4 didn't work. But, after a little more searching, I ended up following the suggestion here and used mp4box to ...


1

When you choose Export Media from Premiere Pro CC 2017, there are options to either Queue the export request (which sends to Media Encoder, aka AME) or Export directly, which, as it says, directly exports media without going through AME. Perhaps your Console log has some notes about what your system doesn't like about AME (or vice-versa). On my system it ...


1

In Media Encoder you first need to select your destination format as Quicktime. From there you should be able to find ProRes 4444.


1

This is most likely just a rounding error in the display of a floating point integer. Even if that is not the case, 0.00003 fps is one extra frame every nine and a half hours of video. If the software consuming this file can not handle that, you should change that component, not the encoder.


1

Importing from AE using dynamic linking and rendering in Premiere or Media Encoder will yield the same quality, but it does give you a little less control over the render settings. While in AE you can choose whether to render with frame blending , motion blur, draft settings and so on, Premiere will always render your AE comp with the current settings. So ...


1

They do on Windows, you need to use the AVI container as HuffyUV isn't available as a quicktime codec, afaik. I used huffyUV for a while, but have switched to magicYUV which has a better range of colour space support (including 10-bit in beta). UTVideo is another good option and is available for mac. With the Premiere - After Effects - Media Encoder ...


1

After effects should take in the image sequence just fine. No reason to run it through Vdub first. Let me know how it works out for you, it sounds like a very interesting project.


1

Unfortunately I couldn't find it in Adobe Encoder preferences - there is no such settings, and by default it loads 30fps sequence. You can change the default in Media Encoder by going to the Preferences/Media and then change "Indeterminate Media Timebase"


Only top voted, non community-wiki answers of a minimum length are eligible