I have a few avi videos that are encoded with the mp4v fourcc codec. I have Sony Vegas Pro 8 and it will not open the video part. It will bring the files into the file manager, but when I drag them into the project timeline they only show the audio track as if there is no video track at all. There is no error message at all.

I would like to be able to resolve this without converting the files.


2 Answers 2


I resolved this issue by installing VLC. Apparently VLC has some necessary codecs that Vegas Pro uses.

After installing VLC I was able to import the video and use it normally with no hindrances.

After some time, this issue cropped up on a different computer. Installing/reinstalling VLC did not work.

I installed AVI Codec Pack Pro v2.4.0 from Softpedia and the issue was resolved.

If Softpedia no longer has the file available by the time you are reading this, the file was titled "avi.codec.pack.pro.v2.4.0.setup.exe" and was 16.7MB (17,538,685 bytes). A google search at the time of update yields other sources for download, but some are concerned with malware imbedded in it. I haven't noticed any malware with the softpedia download.

  • AVI codec pack still working and available as of this date.
    – user3643
    Commented Apr 25, 2016 at 16:53

To get the proper codecs supporting FOURCC of MP4V you can install ffdshow codec pack http://www.videohelp.com/software/ffdshow/old-versions some of the older versions are nicer. the one i use the most is rev3631 because its the last one that contained the MPEG1 and MPEG2 encoders/decoders with it.

  • That's how I was able to record with the codec in the first place. ffdshow seems to have the encoder for MP4V, but not the decoders, or at least, not any decoder Vegas Pro will use.
    – user3643
    Commented Feb 7, 2016 at 2:03
  • ahh, for the decoders, you might need to run the vfw configration or decoder configurations that come with ffdshow. When you look there, ensure mpeg4 is enabled, or maybe its divx, or mp4, not sure how it might be listed. Commented Feb 7, 2016 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.