2

Just set up my new Rode Podcaster and trying to figure out how to monitor both the mic and the system sound from my mac. Using it for podcasting, so I want to be able to monitor myself and the person I'm interviewing. The Podcaster mic includes a line out for monitoring, but it doesn't include system sound. Conversely, jacking my headphones into the computer allows me to monitor the other person I'm speaking w/ (typically via skype) but not the mic.

Help!

  • I have (had) the same question. The only answer I found was superuser.com/a/58191. – user3405 Jan 2 '13 at 21:57
1

In general, I'd say don't bother. Just do a bit of pre-recording testing to make sure your input levels are good. You're not going to want to tweak the input levels a bunch while you're recording, anyways. That would just be distracting to you and the other people that are recording.

But if you really want to, and you're on a Mac, check out "Line In" from Rogue Amoeba: http://rogueamoeba.com/freebies/ - I just tried it out, and it works great.

If you're on windows, this may work http://answers.microsoft.com/en-us/windows/forum/windows_vista-pictures/how-to-get-the-microphone-sound-through-speakers/1643d977-5dfb-4eca-9330-3b16370e7646 though I haven't tried it (don't have my windows machine ready to try it out). There are other options, as well, like software packages you can purchase.

One thing you need to know, though, is that you'll end up with a small delay between your actual voice and what you're hearing through your headset. It's not much of a delay, but it is noticeable. This can be confusing if you're not used to it. You might accidentally start to slow down or pause or get mixed up because you're hearing yourself slightly after the moment that you are speaking. It tends to make people think they are interrupting someone else, and can cause stumbles in speaking.

If you've done any studio recording, this shouldn't be too much of a problem. But if you've never done anything like that, it can be disconcerting. So if you're going to go down the path, be sure to practice recording yourself with this feature on. Get used to the way it works, and the output levels that you need for the recording vs what you are hearing.

| improve this answer | |
  • I prefer to monitor the mic while recording, to make sure I notice if I start breathing into the mic, or if I move too far away from it, etc. I've heard that, since this answer was written, delays have mostly become a thing of the past, due to faster computers/interfaces/cables/etc. I haven't experienced it, even with a cheap USB mic. – Ian Dunn Apr 7 '17 at 21:37
0

For Skype and GarageBand, these steps worked for me:

Setup

  1. Install the latest Soundflower release. You don't need the SoundflowerBed GUI app (which is retired), just the kernel module itself.
  2. Under Applications > Utilities > Audio MIDI Setup
    1. Create a new aggregate device, name it Skype + Mic (or whatever descriptive name you want)
    2. Check the Use box for your mic and Soundflower (64ch)
  3. Under Skype > Preferences > Audio/Video
    1. Microphone: Your mic
    2. Ringing: Soundflower (64ch)
    3. Speakers: Soundflower (64ch)
  4. In GarageBand
    1. Track menu > Enable Multitrack Recording
    2. Under Preferences > Audio/MIDI
      1. Audio Output: Your headphones (make sure you use headphones and not speakers, to avoid feedback)
      2. Audio Input: Skype + Mic (or whatever you named the aggregate device)
    3. Create two tracks:
      1. Name one of them Mic, set Input Source to Mono 1 (Skype + Mic), turn Monitoring on, and click the small red Record icon to enable recording
      2. Name the other one Skype, set Input Source to Mono 3 (Skype + Mic), turn Monitoring on, and click the small red Record icon to enable recording
      3. The red buttons above are the small red buttons in the track itself, not the big red button at the bottom that starts recording.
  5. Reboot the machine, just to be safe. It shouldn't be necessary, but it seems like it might be.
  6. Open Skype and make a call to the echo123 account, which is an official bot that they run to help people test things like this. Make sure you're connecting to that exact username, though, since it looks like there are a lot of phishing bots trying to impersonate it.

Troubleshooting

If it doesn't work, then double-check all of the settings, reboot, and try again.

Sometimes Skype will revert to Soundflower (2ch) when other settings change, so make sure it's set to 64ch.

Sometimes GarageBand needs to be restarted to recognize changes in input sources, but it's best to just restart the entire machine after the settings are correct.

Miscellaneous

Other DAWs and videoconferencing apps should follow a similar process. I'd recommend keeping the main system Input and Output at their defaults, and only change the input/output for the DAW and conference app.

(Source)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.