0

When calling ffmpeg it keeps defaulting to Arial-MT / Arial-BoldMT even when specifying a font. How do you correctly specify the fontfile?

When specifying any font it will always default back:

[Parsed_subtitles_0 @ 000001915a83f800] fontselect: (DosisBold, 400, 0) -> ArialMT, 0, ArialMT

I am calling ffmpeg with the following command:

ffmpeg -i input.mp4 -vf subtitles='subtitle.srt':force_style='FontName=DosisBold,Alignment=10,Fontsize=24' output.mp4 -loglevel debug

I have a file called "DosisBold.ttf" in the same folder as ffmpeg. I have already tried FontName=DosisBold.ttf and it also doesn't work. All files are in the same folder as the ffmpeg.exe.

I have converted the .srt file to .ass and specified the font file but it still defaults back to ArialMT.

Format: Name, Fontname, Fontsize {...}
Style: SubStyle,DosisBold,24 {...}

I am using "ffmpeg-n7.0-latest-win64-gpl-7.0", I have tried different versions of ffmpeg (e.g. "ffmpeg-master-latest-win64-gpl") and still no change. Also tried different fonts / font files and it always defaults back to Arial.

1 Answer 1

0

try this :

ffmpeg.exe -i "filename" -filter_complex "subtitles=filename.ass:fontsdir=./fonts:force_style='FontName=Arial Rounded MT Bold,PrimaryColour=&H0000FFFF,SecondaryColour=&H000000FF,OutlineColour=&H00000000,BackColour=&H20000000,BorderStyle=4,Fontsize=17'" -c:v libx264 -crf 20 "$filename.mp4"

With a font directory with your font (here : ./font/ARLRDBD.TTF) and the name of your font not ttf file name (here : Arial Rounded MT Bold).

Enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.