0

I'm trying to correct lens distortion of a video.

I use below code that I took from here: https://ffmpeg.org/ffmpeg-all.html#Examples-132 (I just change the input and output file paths).

ffmpeg -i input.mov -vf lensfun=make=Canon:model="Canon EOS 100D":lens_model="Canon EF-S 18-55mm f/3.5-5.6 IS STM":focal_length=18:aperture=8 -c:v h264 -b:v 8000k output.mov

But I get this error:

[Parsed_lensfun_0 @ 000002a85a0f7ac0] Failed to load lensfun database from default path
[AVFilterGraph @ 000002a8638fa880] Error initializing filters
Error reinitializing filters!
Failed to inject frame into filter network: Invalid data found when processing input
Error while processing the decoded data for stream #0:0
Conversion failed!

How can I resolve this issue?

I tried to give full path with db_path command as seen below:

ffmpeg -i input.mov -vf lensfun=make=Canon:model="Canon EOS 100D":lens_model="Canon EF-S 18-55mm f/3.5-5.6 IS STM":focal_length=18:aperture=8:db_path=E:\lensfun-master\data\db\slr-canon.xml -c:v h264 -b:v 8000k output.mov

And I get this similar error:

[Parsed_lensfun_0 @ 0000020b955cb7c0] Failed to load lensfun database from E path
[AVFilterGraph @ 0000020b94e2e9c0] Error initializing filters
Error reinitializing filters!
Failed to inject frame into filter network: Invalid data found when processing input
Error while processing the decoded data for stream #0:0
Conversion failed!

Am I doing something wrong?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.