I managed to create the subtitle file, using different language with one single FFMPEG command:

ffmpeg -y -loglevel "repeat+info" 
-i "file:Intervista.mp4" 
-i "file:Intervista_fr.srt" 
-i "file:Intervista_en.srt" 
-i "file:Intervista_it.srt" 
-c copy 
-map 0 -dn -map "-0:s" -map "-0:d"  
-map "1:0" "-metadata:s:s:0" "language=FR" "-metadata:s:s:0" "handler_name=French"  "-metadata:s:s:0" "title=French" 
-map "2:0" "-metadata:s:s:1" "language=ENG" "-metadata:s:s:1" "handler_name=English" "-metadata:s:s:1" "title=English" 
-map "3:0" "-metadata:s:s:2" "language=ITA" "-metadata:s:s:2" "handler_name=Italiano"  "-metadata:s:s:2" "title=Italiano" 

For some reason, the default subtitles shown when I start the video is English, which is the one in the middle. How do I set the default subtitle file to Italian?

1 Answer 1


Add -disposition option :

-disposition:s:0 0 -disposition:s:1 0 to clear the disposition for first and second subtitles (fr and eng).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.