I cut videos using the command below, and I sometimes find that the resulting video has imperfections at the beginning (square artifacts in the image). If I advance the start time parameter value (START_AT_SECONDS) by a few seconds (usually 1..3s), the artifacts go away.

Is there a way to avoid the hit-and-miss, e.g. to know in advance that START_AT_SECONDS=53 works but START_AT_SECONDS=52 will give artifacts? Is there an option that means "START_AT_SECONDS=52, or later as needed to make a good cut"?

ffmpeg -ss START_AT_SECONDS -i "some_file_name.mp4" -t DURATION_SECONDS -c copy "new_name.mp4"

1 Answer 1


There is a mistake in your ffmpeg command.

The -c option either needs a codec (e.g. -c:v libx264) if you want to encode the video or the special value "copy" if it shouldn't be re-encoded (-c copy).

Using -ss together with -c copy might not be accurate since ffmpeg is forced to only split on i-frames. But starting on an i-frame should fix the problem with artifacts.

  • Apologies, I was already using "-c copy new_name.mp4". I have updated the question to reflect that. Jul 29 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.