I have a Adobe Premiere Pro CC 2017 project with an mp4 in the sequence.

That mp4's sound plays fine in Source Monitor.

And its sound plays fine if I right-click the mp4 in the Project panel and choose Modify > Audio Channels > Preview Media Source Channel.

But this mp4 clip's sound does not play in Timeline.

In Timeline, the track itself does not have the muted M enabled. I've tried toggling that back and forth too, just to be sure. I've also tried the trick of clicking the S to solo the audio of this clip or others (and then disable all S buttons).

The Audio Clip Mixer panel seems disabled when this clip plays in Timeline. But Audio Clip Mixer works (and shows dynamic levels of sound) when other clips in this project play.

In Effect Controls > Audio Effects > Volume, I see 6.0 dB. Changing this value up or down doesn't seem to help.

How can I get the audio back for this clip?

P.S. I've also tried Edit > Preferences > Media Cache > Media Cache Database > Clean.

1 Answer 1


I would appreciate a better answer than this because although I finally found how to get the sound back, I still don't fully understand what is going on here.

I stumbled onto the Remove Attributes menu when right-clicking a clip.

Removing "ERA4_ReverbRemover" from each of my clips seems to restore their audio.

screenshot of Remove Attributes

I still don't know:

  • What ERA4_ReverbRemover is
  • How or when it got added to these clips
  • Why it removed their audio completely
  • What are the risks of me removing this attribute from each clip

I'll gladly accept a better answer. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.