I'm trying to convert an rgba png to prores 4444 with an alpha. When I run the following command it will create prores file with an alpha. But, the alpha is full white, it doesn't retain the values I put in.

ffmpeg -start_number 1001 -r 24.000 - "pngWithAlpha_%06d.png" -c:v prores_ks -profile:v 4 -alpha_bits 16 -y "proresWithAlpha.mov"

I've tried this with both FFMPEG 4.2.2 and 6.0.0 on a linux system, I'm not sure if I'm doing it wrong or if it is a bug.

Looking at this post it seems it should be possible (they're complaining about quality not a fully missing transfer of the alpha).

I would expect it to pass the alpha straight through but it doesn't. I used alpha_extract to copy the alpha in to the rgb to confirm I'm able to read the alpha from the png, which worked. But the alpha was still full white.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.