0

ive been using ffmpeg and recover mp4 to try and restore a dashcam video from a car accident. im a beginner using this method/ software and im running into this issue. not sure how to "increase analyzeduration and probesize" any and all help appreciated ASAP

C:\ffmpeg-2023-03-20-git-57afccc0ef-essentials_build\recovery\bin>ffmpeg.exe -r 25.000 -i result.h264 -i result.aac -bsf:a aac_adtstoasc -c:v copy -c:a copy result.mp4
ffmpeg version 2023-03-20-git-57afccc0ef-essentials_build-www.gyan.dev Copyright (c) 2000-2023 the FFmpeg developers
  built with gcc 12.2.0 (Rev10, Built by MSYS2 project)
  configuration: --enable-gpl --enable-version3 --enable-static --disable-w32threads --disable-autodetect --enable-fontconfig --enable-iconv --enable-gnutls --enable-libxml2 --enable-gmp --enable-bzlib --enable-lzma --enable-zlib --enable-libsrt --enable-libssh --enable-libzmq --enable-avisynth --enable-sdl2 --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libaom --enable-libopenjpeg --enable-libvpx --enable-mediafoundation --enable-libass --enable-libfreetype --enable-libfribidi --enable-libvidstab --enable-libvmaf --enable-libzimg --enable-amf --enable-cuda-llvm --enable-cuvid --enable-ffnvcodec --enable-nvdec --enable-nvenc --enable-d3d11va --enable-dxva2 --enable-libvpl --enable-libgme --enable-libopenmpt --enable-libopencore-amrwb --enable-libmp3lame --enable-libtheora --enable-libvo-amrwbenc --enable-libgsm --enable-libopencore-amrnb --enable-libopus --enable-libspeex --enable-libvorbis --enable-librubberband
  libavutil      58.  4.100 / 58.  4.100
  libavcodec     60.  6.101 / 60.  6.101
  libavformat    60.  4.100 / 60.  4.100
  libavdevice    60.  2.100 / 60.  2.100
  libavfilter     9.  4.100 /  9.  4.100
  libswscale      7.  2.100 /  7.  2.100
  libswresample   4. 11.100 /  4. 11.100
  libpostproc    57.  2.100 / 57.  2.100
[h264 @ 0000025867b3dac0] Format h264 detected only with low score of 1, misdetection possible!
[h264 @ 0000025867b4f940] missing picture in access unit with size 23
[h264 @ 0000025867b4f940] no frame!
[h264 @ 0000025867b3dac0] Could not find codec parameters for stream 0 (Video: h264, none): unspecified size
Consider increasing the value for the 'analyzeduration' (0) and 'probesize' (5000000) options
Input #0, h264, from 'result.h264':
  Duration: N/A, bitrate: N/A
  Stream #0:0: Video: h264, none, 25 tbr, 1200k tbn
[aac @ 0000025867c0e5c0] Format aac detected only with low score of 1, misdetection possible!
result.aac: End of file

C:\ffmpeg-2023-03-20-git-57afccc0ef-essentials_build\recovery\bin>
C:\ffmpeg-2023-03-20-git-57afccc0ef-essentials_build\recovery\bin>
2
  • Add -analyzeduration 100M -probesize 100M before each of -i result.h264 and -i result.aac.
    – Gyan
    May 5, 2023 at 4:07
  • Although it looks like your aac file is very short.
    – Gyan
    May 5, 2023 at 4:08

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.