I have very little experience with FFmpeg but a process that worked flawlessly on one video (60fps @1920x1080) is dropping frames like crazy on another (58.56fps @1920x1080).

I believe I have my offsets right (1/60= 0.0166 and 1/58.56 = 0.01707) but the proessr said drop=0 on the first one but drop=[greater than framecount] onthe second Can't see what element in the code is telling it to do that, or how to change it.

Here's my code for the first 60Hz file which worked nicely:

ffmpeg -i G:\PropFlicker.mp4 -itsoffset 0.01666 -i G:\PropFlicker.mp4 -filter_complex color=0x202020:r=60:s=1920x1080:d=24[mask];[mask][0][1]maskedmax=[out] -map [out] -crf 10 G:\PropNoFlicker.mp4

And here's the report with no frames dropping:

enter image description here

Here's my code for the second file at 58.56Hz:

ffmpeg -i C:\20150104_164428.mp4 -itsoffset 0.01707 -i C:\20150104_164428.mp4 -filter_complex color=0x202020:r=58.56:s=1920x1080:d=60[mask];[mask][0][1]maskedmax=[out] -map [out] -crf 8 -r 58.56 G:\Output.mp4

And here is the report where you can see frames dropping like crazy

enter image description here

I don't know what -crf does and if it has anything to do with it, and I also tried changing the d=60 to other values, makes no apparent difference. No idea what duration that is changing either

I tried with and without the last -r 58.56 and it made no difference.

Any help will be appreciated!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.