I have a Behringer BCF2000 which I recently purchased on eBay.

Video example of the problem:

It's an older device with motorised faders which can function as a MIDI controller or as a Mackie control surface.

I want to use it as a control surface inside Adobe Premiere CC 2023 and Audition, mainly to adjust levels on projects.

I have connected the Behringer to my M1 MacBook Pro via USB. I'm running MacOS Ventura.

I have followed this video precisely, and tried rebooting the Behringer into modes 2 and 4, which are supposed to be:

  • Mode 2 = Mackie Control (Cubase and Nuendo)
  • Mode 4 = Mackie Control (Sonar)

I can write volume moves from the Behringer into Premiere / Audition. I cannot get those moves to play back on the motorised faders in any way.

When I set the faders to Read mode in Premiere, and play back my project, all the faders on the Behringer jump to zero and do not move.

In the video he says to use Mode 4. I have tried Modes 2 and 4 without success. After powering up the Behringer with the 4th button held down, I then press the Exit button. This isn't mentioned in the video, but without doing it, the Behringer never appears as an interface to the Mac.

When my Behringer powers up, it appears to be using Firmware 1.10. In the video he is using 1.07.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.