I'm trying to transcode a h264 stream to h265 for better bandwidth utilization, but I got massive artifacts on h265, which were not presented on h264:

enter image description here

I'm using ffmpeg to do this, on a live stream (so 2nd pass is not an option, or at least I have no idea on how could I do 2nd pass, maybe with some massive buffers?).

ffmpeg -re -i HLS_SOURCE -c:v libx265 -preset ultrafast -b:v 600k -max_muxing_queue_size 4096 -force_key_frames source -x265-params "scenecut=100" -acodec copy -rtpflags latm

I tried some basic options: force_key_frames source and scenecut=100 but they don't really solve this (as you can see on my sample image).

Can I do something to make this better?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.