0

I'm trying to use ffmpeg to create a cropped "boomerang" video. Where it would take in a video, take a small segment, crop it and then play that little piece forward and then play it backwards.

ffmpeg -y -i x.mp4 -c:v libx264 -filter_complex 'trim=start=1.32:duration=0.4,crop=500:500:1200:300,split=2[f][ri];[ri]reverse[r];[f][r]concat' x1.mp4

The end result, however, is 00:00:02.34 long, almost the exact same as the original 00:00:02.46. What am I doing wrong?

1 Answer 1

1

Reset timestamps after the trim, and disable audio.

ffmpeg -y -i x.mp4 -c:v libx264 -filter_complex 'trim=start=1.32:duration=0.4,setpts=PTS-STARTPTS,crop=500:500:1200:300,split=2[f][ri];[ri]reverse[r];[f][r]concat' -an x1.mp4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.