I have a 3840x2160 MOV file taken with my EM1.II Olympus camera. It is a videoclip of a tiny bird taken in the wild without any aids. Hence, despite the good stabilization feature of the camera, the bird moves quite a bit along the frame. I want to stabilize the video USING LINUX ONLY (Fedora 35 fully updated).

I can crop A LOT, since the bird is quite small in the frame. Yet, the bird moves quite a bit in the frame, in a circle of around 800 pixels in diameter. But the video is not "blurred": the bird is fixed and sharp most of the time, thanks to the stabilization of the camera.

I tried to install Blender, but it does not run complaining about my old video card. I then tried Kdenlive without luck: the motion tracker effect was removed last year. So the natural clues I found in Google do not apply anymore.

Anyway, there should be a good way to stabilize the video using ffmpeg and other software. ffmpeg comes with a stabilization feature, but it only works for small movements, and my movements are not small at all.


1 Answer 1


DaVinci Resolve (free version) works on Linux and has good stabilization. I'm currently running Resolve 17 on Pop! OS 21.1 without a problem. To make a Debian type installer I used https://www.danieltufvesson.com/makeresolvedeb

Edit: Somehow missed that you are on Fedora, however it does seem like some folks have it running on that distro.

  • Yes, thanks, I will try it. Here is a page for installing in Fedora: fosslinux.com/40081/… Commented Feb 14, 2022 at 20:42
  • No luck. I installed it without problems, but when I run /opt/resolve/bin/resolve only a black window appears that I have to CNTR-C. Then it refuses to run again crashing. Commented Feb 14, 2022 at 22:49
  • @LuisA.Florit the comments on the link you posted suggest there are problems installing Resolve 17 on Fedora.
    – moorej
    Commented Feb 15, 2022 at 0:53
  • @LuisA.Florit You could try installing an older version like Resolve 16.1.1 Older versions are available here: blackmagicdesign.com/support/family/davinci-resolve-and-fusion
    – moorej
    Commented Feb 16, 2022 at 5:23
  • I tried 16.1.1. Exactly the same problem happens. It seems there's a problem with log4cxx: forums.centos.org/viewtopic.php?t=61600 Commented Feb 16, 2022 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.