I've been using kdenlive to make videos on ubuntu for a while and the screen grab has been fine but, for some reason (probably something I did to try to get the desktop start button to work on ubuntu 20.04) my display has changed from :0 to :1

I have been able to muddle on by starting screen capture in a terminal with

ffmpeg -video_size 1306x745 -framerate 25 -f x11grab -i :1.0+60,23 ./scrgrab01.mp4

Then importing each of the clips into kdenlive. But it's a bit messy having to edit a terminal command and remember which clip is which. Also I have now set up a desktop computer with more muscle and want to use that for rendering but that too has the display :1 not :0

I tried going into configure->capture->manage encoding profiles and trying to add ffmpeg arguments like

-crf 25 -i :1.0+60,23 -vcodec libx264 -preset veryfast -threads 0

(and lots of different permutations of that) But nothing has worked so far.

Is there something really obvious that I have overlooked?

1 Answer 1


From what I can see, kdenlive is hard-coded to use DISPLAY :0, while ubuntu and gnome/gdm have switched (around ubuntu 18??) to put the user on DISPLAY :1. When I tried the lightdm manager, I found that it still has the older convention of putting the user on the :0 DISPLAY, which is compatible with kdenlive screen grab. So if you don't mind switching window manager, that could be a way to do it.

I also tried to understand if it is possible to have gdm3 put the user on DISPLAY :0 as a default at boot time through some custom configuration, but couldn't figure it out.

In the user's gdm3 session that is on :1 by default, I also tried to set DISPLAY :0 in an xterm and start kdenlive from the command line in that xterm. However, for some reason I got a Qt error doing that, and so I couldn't tell if that was a useful workaround or not.

Note that kdenlive screen grab has some wonky behaviour, which made it harder for me to understand this problem. The 21.12.3 version I was using didn't show me the error output from the ffmpeg command, and it was only by chance I tried the 22.04 version this evening (which was scheduled for release tomorrow but I guess it went out early) and it did now show that error output.

Note also KDE documentation talks about a need to obtain an ffmpeg binary compiled with --enable-x11grab (or more properly, --enable-libxcb) in order for kdenlive screen grab to work. In fact, I don't seem to need this ffmpeg option to get a screen grab. It was just the DISPLAY business that had to be fixed.

  • Thanks for suggestions @JB it might be worth doing a few tests, but for anything too complicated it will be easier to just middle on with ffmpg
    – paddyg
    May 13, 2022 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.