1

I'm looking for a solution to be able to shoot with my Canon 1Dx and have the footage straight on my 2019 MacBook Pro with Big Sur (v 11.2.2) and I'm stuck. Here is what I have tried and what issues I have encountered or what does not suit me:

  • I installed Eos Webcam Utility (v1.0.2) which allows my 1Dx to be used, via the USB cable, as a webcam in many applications. But I can't get the video stream back to Quicktime Player (which I think would have fixed my problem).
  • With Eos Webcam Utility provided by Canon (EWU in the following), I manage to retrieve the stream in OBS but it does not allow (or I cannot find how) to retrieve the raw stream and it is forced to transcode it. And it consumes a lot of resources which leaves me the choice between recovering a stream of not even 720p or losing a lot of frames, like 50%, or even more, which is not ideal.
  • With FinalCut Pro X Trial (v10.5.1), I thought I had found a solution. But I've found that many times when I stop importing it doesn't save the file (I'm not sure but it seems related to timecode breaks). So I don't want to shoot for a while to find out that it didn't work.
  • I tried with the Elgato Cam Link 4K but was only able to get the camera screen with the OSD, without having the ability to record it in Quicktime or Final Cut.
  • I also tried the network options provided by the 1Dx:
    • the FTP mode can only transfer images, not videos.
    • The web server mode allows control but not video capture.
    • What comes closest to what I would like is the mode that allows you to control it with Eos Utility 3. The only problem is that it cannot take video while the files are being transferred from the memory card so all transfer time is wasted time.

In addition to that, for several days now, I'm no more able to get the image of my 1Dx in Final Cut. When I try to switch to liveview mode, the 1Dx shows me the message "busy". If I unplug the USB, I can activate the liveview mode, but as soon as I reconnect the cable, the liveview mode stops. Final Cut shows me the Canon image all the time with the USB cable unplugged.

If you ever have a solution, I'm interested. Thank you in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.