1

When linking an AE comp through PP, the audio won't sync. This has been an issue forever. I film skate/bmx videos and it's essential that the speed ramp syncs with the audio so you can hear the cool distortion of a slow mo grind. Sometimes I can get by just cutting and stretching audio in Premiere, but that is NOT a solution.

The ONLY thing that I found to work is to unlink the "composition" type from the attached MPEG clip. As soon as you click "replace with AE..." (in PP) and are automatically redirected, immediately delete anything in the timeline. Then, select the MPEG clip ONLY and drag it into the timeline again. There is no linked source info at this point, so your clip will play from the beginning as if you hadn't cut anything in PP. Because of this, in AE you'll need to go to Composition>Compositions Settings and find duration at the bottom. Whatever the AE comp length is will be what your original PP cut length was. Ex) If the original clip is 20s long, but you're cut is only 5s in PP, AE will only play the first 5s of your clip. So, change the duration to any length that you know will contain the part you'd like to edit. Usually, I just increase the time by 10s, and can always add length by going back to comp settings.

Edit your time remapping/speed ramp.

Once finished, go to Export>Add to Render Queue. In your timeline window, click on Render Queue and under "Output to:" change the name of your clip (if you'll have a lot of AE comps in PP). Click "Render" on the right of the window. Then in Premiere, import the clip from wherever you saved it and treat it like an entirely new clip.

There has to be a better way, but I haven't seen anyone come up with something easier so hopefully this helps someone.

Is there any way to keep AE comps linked to a PP project AND keep ramped audio synced?

1

Adobe Dynamic Link is a great tool, but unfortunately at the end of the day it can be problematic as it has its limitations. As After Effects is almost entirely focused on video, it doesn't surprise me that audio would be one of these limitations.

Before dynamic linking existed, we always had to do round-tripping (sending files to another program, working on it there, and then sending a new rendered copy back to replace in the original program's timeline). Visual effects work in the Adobe Suite that hits these limitations with linking, such as this sound-related one you've run into, just means that you have to resort to this old-fashioned method as you've found.

In fact because dynamic link can cause problems, if I'm doing anything other than basic text or whatnot I only use the "Replace with AE..." tool to send clips to AE. After it's sent over, I hit Ctrl+Z (undo) in Premiere to undo the timeline, breaking the link and getting back the original clip that I just sent in the proper place/time.

Therefore, I'm always exporting a fresh clip straight out of After Effects to drop into the Premiere timeline. There's a few reasons for this:

  • Dynamic linked clips in the Premiere timeline use a TON of processing power because it's doing the calculations for the dynamic linked clip on the fly, like when you play it back in After Effects without any ram preview cached. You've probably noticed that it can stutter and struggle to make it through a linked clip when you're playing through the timeline, and sometimes slow you down even when you're not looking at it because it's anticipating. For anything remotely intensive, I unlink after sending to AE to avoid this problem, and round trip it back.
  • Similarly, round-tripping also saves you tons of render time on the video when you're rendering out the Premiere file. Let's say you watch your final render and notice you misspelled something in the credits or a cut is off-time. Re-rendering means it's going to have to recalculate all of the dynamically linked clips again, whereas if you had your individually rendered VFX clips in the timeline, it can breeze through them as it's just a normal video file.
  • The dynamically linked clip is Premiere's interpretation of the After Effects file, and Tthis can cause some issues and visual glitches with dynamic link rendering just as can happen when dynamic rendering AE files in Media Encoder. These are usually really specific issues with transparency, color science, plugins, and even sometimes referring to the wrong composition or a seemingly old version.

I know it's quite annoying, but you've clearly gotten the basic concept of how to round-trip it without the link. Here's a few things that could help or improve your workflow:

  • Like you said, you can increase the AE comp time to give you more working room. However to avoid having to do it multiple times, I suggest you just add more time than you know you'll need, and use the "trim comp" tool at the end of your process. Drag the work area range to where your final length should be, right click it, and select trim comp to work area.
  • To expand on your point on organizing, my suggestion is to create a folder (in your OS explorer) parallel to your footage folder where you can save your new clips. Use a consistent naming convention so that you can always match it with the original clip. For instance, original file: A002_C003.mp4 should be saved as A002_C003-VFX001.mp4 or some other format which distinguishes it as the modified clip, and also allows for revision files to be created without having to go "-VFX-ACTUALfinalfinal2," hahah.

Additionally, I'm sure you'll be able to find some other ways to shave time out of your workflow. If you haven't already, try to learn the After Effects hotkeys as it will save you a lot of time with even these steps you're describing.

I hope I helped at least somewhat! Sorry there's not a more convenient way, but I also recommend reporting this as a bug to Adobe, as it really should be a true functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.