0

I have a video and a soft subtitle of the video.The video had 3 audio(track1 track2 track3) I use this command

ffmpeg -i /sdcard/input.mkv -vf subtitles=/sdcard/input.ass /sdcard/hrdcoded.mp4

In this command I not only hardcode subtitles but also convert the video to mp4. The process start properly but when it finished I saw I was have 3 audio track(track1 track2 track3) now it have audio track1. Other tracks are missing. What command should i use to have all audio track

0

FFmpeg, by default, only picks one stream of each type (video, audio, subtitles). The user needs to set map option to select tracks for an output.

ffmpeg -i /sdcard/input.mkv -vf subtitles=/sdcard/input.ass -map 0 -c:a copy /sdcard/hrdcoded.mp4

See https://ffmpeg.org/ffmpeg.html#Stream-selection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.