0

Question

I wish to know — in my own particular case — why the conversion of VOB files to mp4 files using ffmpeg results in files of only about one quarter the size, whether this reduces the quality and, if so, how to ameliorate the effect.

The commands I am using are of the type:

ffmpeg -i VTS_01_1.VOB -q:v 0 VTS_01_1.mp4

I understand from my research that “-q:v 0” specifies maximum quality.

I also gather from the answer to a related question that the bitrate and codec could be affecting the reduction in file size, but I have no idea how to experiment with these parameters in my case.

Background

I am converting commercial DVDs produced by a friend who is a retired Hollywood technician. The DVDs are instructional DVDs for a particular textile craft and typically involve two, three or four discs, made on a Mac using an old copy of Final Cut Pro. With the decline in DVD drives on computers my friend has started also to distribute the files on thumb drives after I suggested I could convert the DVDs to mp4s. I had played with free software for my own purposes, although I know next to nothing about video, but I am familiar with the unix interface on my Mac and discovered that ffmpeg seemed better than the GUI software for converting and then concatenating the various VOB files. The reduction in file size seemed a bonus as it allowed him to use 8Gb thumb drives. For some of the DVD conversions he felt there was no loss in quality, but for the latest one (done exactly the same by me) he reckoned some loss was noticeable (size reduction from about 10Gb to 2Gb — a bit more than usual). The “Get Info” on the videos includes the following:

Kind: MPEG-4 movie
Dimensions: 853 × 480
Codecs: AAC, H.264
Audio channels: Stereo
4
  • 1
    The default codec for MP4 - x264 - is a lot more efficient than the default codec for DVDs - usually Mainconcept's MPEG-2. However, the quality loss is more likely to be due to lack of deinterlacing. Add -vf yadif=0 and check.
    – Gyan
    Oct 17, 2020 at 13:47
  • @Gyan — I repeated the rip with the options you suggested and sent the video to my friend. However, unfortunately, he does not think there is any improvement. In fact the quality isn't that bad, and he is going to distribute the mp4 version as is, but it would be have been better if I had been able to fix it. Thanks again for your effort to help. I have noted your info for possible future use.
    – David
    Oct 19, 2020 at 22:11
  • @Cdon meant to comment: "I'm in same spot. I don't know if my qualities worse but I'm suspicious of reduced file size. Did u find a solution? Thank u? The answer is that I think there is no problem with the quality after all. I bought a film movie of an opera (Joseph Losey's Don Giovanni) which was in the original operatic Italian with German subtitles, for which there was no turn-off option. I ripped it as an mp4 so I could strip out the subtitles, and then found software to make it into a DVD again to sell it on. The mp4 was smaller, as usual, but the DVD reflated to the original size.
    – David
    Jan 20 at 23:34
  • @Cdon — But I may be wrong. See the answer to this similar question I just found: video.stackexchange.com/questions/18582/…
    – David
    Jan 20 at 23:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.