The way it is the spectrogram doesn't even reach through my screen after two minutes of playback. I want 30 seconds at most.

  • Welcome! It isn't entirely clear what you are asking. Are you saying that the generated spectrogram only fills part of the screen when you want it to fill your entire screen by 30 seconds in to a longer piece of audio? Please share the exact ffmpeg command you are using and the full console output. Sep 7, 2020 at 18:14
  • Hi! I want it to scroll quicker, to fill the screen quicker and to show more detail.
    – mzso
    Sep 8, 2020 at 20:23

2 Answers 2


Carefully read filter documentation, you need to change option overlap to some higher values. At cost of more CPU usage.

  • Thanks! That worked. I see "Set ratio of overlap window. Default value is 0. When value is 1 overlap is set to recommended size for specific window function currently used." in the documentation. I wonder what the specific window functions change or what they base the recommended size on, or what even overlapping means in this context.
    – mzso
    Sep 10, 2020 at 8:57
  • It closely match algorithm used to display audio spectrum using FFT. The default overlap is just one that makes sense to use in typical scenario.
    – user12174
    Sep 10, 2020 at 19:44

I am not sure your difficulties , but do examples from this link help?

  • I'm ttrying to increase the speed it scrolls at.
    – mzso
    Sep 8, 2020 at 20:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.