2

I want to make a video 'wide', so the width is increased and the height stays the same as of the input image. I use the following command: ffmpeg -i test.mp4 -vf scale="1000:200" output.mp4. It just does not work. The most interesting thing that it works with png images but not with videos. Example: video before:enter image description here

After: enter image description here

7
  • 2
    Add -report and rerun. Share report.
    – Gyan
    Jul 16, 2020 at 5:19
  • a shot in the dark - but as far as I know, you don't need the quotation-marks when defining the scale. Instead, try: scale=1000:200 Jul 16, 2020 at 7:15
  • @Gyan pastebin.com/vm68342n Jul 16, 2020 at 12:47
  • @FlorianClaaßen I tried, it did not work Jul 16, 2020 at 12:48
  • @BakhanovA. Huh, was worth a try. Jul 16, 2020 at 14:12

1 Answer 1

2

I resolved this issue by setting the attached SAR (Sample/Storage Aspect Ratio):

ffmpeg -i test.mp4 -vf scale=1000:200,setsar=1 output.mp4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.