0
  1. When using ffmpeg -i input1 -i input2 ... -filter_script filter_complex.txt output.mkv I can't seem to get the stream from the filter_complex.txt file to be recognized by ffmpeg. If I add -map [v], then it doesn't recognize the [v] like it would normally and says there's an unconnected output.

  2. This is less important, but I haven't found a way to do something like ffmpeg -i inputs.txt ... to avoid the character limit yet, so if you know a way to do that, that would be nice.

Reason: I'm trying to use ffmpeg to overlay many images (~100) onto a video at various points and need to use files so I'm not going over the command line limit of 2k-8k characters in windows.

1
  • 1
    For complex graphs, it's -filter_complex_script – Gyan Jul 14 '20 at 18:53
0

I found an answer that worked for me. I was trying to use the -map [v] syntax, but it turned out that wasn't necessary and I could just use the filtergraph I made as is. I did use filter_complex_script, which Gyan pointed out is the correct command, but I'm still not quite sure what the difference between the two is after looking through the documentation.

0

Use -filter_script:v for video.

Ref: https://ffmpeg.org/ffmpeg-all.html#Generic-options

-filter_script[:stream_specifier] filename (output,per-stream)

PS: I just discovered (right now), that you can also use filter_complex_script (:v not needed). -filter_complex_script seems the more advanced approach.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.