0

I'm running Windows 10 and using the built-in Photos app (also called Video Editor from the Start Menu). I want to be clear that this is not the earlier 'Windows Movie Maker" app. I'm trying to do something simple - split a 1.5 minute video into 3 30-second increments. Using the Split feature, it's easy to separate the first 30 seconds from the original clip and save that individually. But when I go to separate the remaining 1 minute, I find that instead of splitting the two clips, Clip 1 is still the first 30 seconds of my video, but clip 2 is also the first 30 seconds of the video, part of the middle of the video, and with 30 seconds cut off from the end of it. I don't want Windows to duplicate the clip - I want it to split into pieces.

Things I've tried:

  • splitting the end off first and going backwards (the problem still happens, just backwards now with the beginning 30 seconds cut from the movie)

  • saving each individual segment and deleting it, hoping that Windows will take the hint that I don't want it repeated in all clips

  • I've tried going into the app itself and clicking "Repair"

  • Also going into the app and clicking "Reset all data", in hopes it was a bug of sorts that could be shaken off.

The internet doesn't seem to have a solution to all this. Most suggestions are for Windows Movie Maker, which I do not have.

Help! What I want to do is pretty simple, I think. Thanks in advance!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.