3

I am currently editing in premiere with time-lapses and have noticed that premiere will use my integrated Intel graphics card instead of my Nvidia GTX 1060. In the Nvidia control panel, I have set premiere to use the Nvidia GPU and have also kept the Studio-Ready Driver up to date. Inside premiere, I have set it to use the "Mercury Playback Engine GPU Acceleration (CUDA)", but still uses integrated graphics. very annoying as it slows the video decoding. Any ideas on how to get premiere to use the Nvidia GPU instead of the integrated GPU?

2 Answers 2

0

Generally, speaking there are a number of issues with systems that have two graphics cards or chips active (unless they are the exact same model).

One option is to disable the Intel card in the BIOS and Premiere won't be able to use it anymore and hopefully uses the Nvidia card. Research for any potential side effects that your system may show afterwards. For example, I did this on one laptop with Windows and Bitlocker encryption active. After disabling the Intel chip it asked me for the Bitlocker recovery key (if I remember correctly). Therefore backup/print out the key before you change the BIOS setting.

0

You need to make sure that your graphics card model is listed within the file "cuda_supported_cards.txt" which can be found in the "Common" folder of where you've installed Premier Pro. C:\Adobe\Premiere Pro\Common for example.

If you don't see GTX 1060 you will want to add it, without NVIDIA in the name, just GTX 1060.

Depending on what version of PPro you are using, the 1060 may have been released after that version, so it wont be on that TXT file list. You'll need to add it to the list like I said above and just save the file.

Also, keep in mind that Premiere will only use the Mercury Playback Engine and utilize your CUDA cores if what you are trying to do, either encoding wise, or effects wise, is supported by CUDA.

Some effects within Premiere, are CPU only, and won't take advantage of your 1060, so there's no way to get around that. It will use your CPU instead and just run off your integrated Intel GPU.

There should be no need to disable your integrated GPU.

However if you do want to disable your integrated GPU, you should do that from within the BIOS settings when you boot. There should be an option inside your BIOS on which GPU to use and you can toggle the Intel Onboard GPU on/off.

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.