1

I have built out a few little animations in After Effects. I'm trying to export them — and pull them into ScreenFlow.

When I export > add-to-media-queue I get a .mov that won't open in QuickTime — and that is “messed up” (for lack of understanding) when I try to use it in ScreenFlow.

enter image description here

It's supposed to look like this:

enter image description here

but it looks like this: enter image description here

I've been able to export it with Adobe Media Encoder — but it has a black background and I can't find how to ensure it comes out with alpha.

enter image description here

Media encoder is being really buggy - and I'm curious is there are problems with the latest releases?

How can a regular ol guy, who's trying to get a basic RGB + Alpha animation, get the job done — the simplest way? I don't even want to know what a codec is... if possible. I plan on staying in the hobbies zone.

3

Click the output mode in the render queue, by default it says lossless: by default it says lossless

use these settings, format: quicktime, video output channels: RGB + Alpha: format: quicktime, video output channels: RGB + Alpha click format options and choose Apple ProRes 4444. The 4th 4 is the indicator that the codec has an alpha channel (this only applies to the Apple ProRes codec naming scheme). format options: Apple Prores 4444 That should fix your problem.

Edit: This was also fixable without changing the codec to Apple ProRes 4444, and could have been accomplished with opening one less window by just switching the color channel to Straight (Unmatted), however... Video Output Color set to Straight (Unmatted) ...knowing whether to choose Straight (no baked-in black) or Premultiplied (baked-in black) is somewhat abstract, and importing video with the default animation codec + aplha into other programs is just weird sometimes.

I've found that ProRes 4444 hits the "it just works" goal more often, and remembering that 4444 corresponds with RGBA(lpha) is easier to recall than the difference between matted vs. unmatted.

1
  • That does the trick! but a little more info - for anyone else coming along would make an even better answer. Why is this the correct codec? Why doesn't the default "just work". Jan 16 '20 at 2:13
0

3 Steps! I was having issues and was able to solve it by rendering in Adobe Media Encoder with the following settings/steps:

  • When ready to export, in AE go to "File > Export > Add to Media Encoder Queue". Media Encoder should automatically open (if not already open) and add your AE file to it's queue.

  • In the Media Encoder queue where your AE file is listed there are two sections with drop down arrows next to them. Click the first arrow and pick "Quicktime" from the drop down menu.

  • Then click the second drop down arrow and pick "Apple ProRes 4444 with Alpha" from that drop down menu.

  • Done! You can click the file path to the right to name your rendered file and choose where it will be saved.

2
  • I actually just did this again today for the first time in months. I ticked rgba though. Did you have to do that? Aug 26 at 4:17
  • The preset I mentioned worked without having to change any export settings. In that preset the Video Codec is "Apple ProRes 4444" and in Basic Video Settings the Depth is "8-bpc + alpha". I imagine that if you choose a depth without "+ alpha" that you'll get black instead of transparent. In the "Apple ProRes 4444 with Alpha" preset there is not a "rgba" box to tick, although I've seen that in other preset settings. Seems like it's a good bet to tick that as the "a" stands for "alpha", which is the transparent part. Aug 30 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.