1

I successfully imported an iTT caption file, and the captions show up fine as white on a black background. The problem is that when I try to edit it in the caption editor, the text is black-on-black, i.e. not visible.

caption editor with black-on-black text

When I drag to select text, the selected text is white-on-purple, so the text is definitely there, just black-on-black.

caption editor with some of that text selected

Obviously this makes it difficult-to-impossible to edit my captions, which need editing. The same problem happens in the Inspector.

All the images I see on line, like this one from Larry Jordan, show white text on a black background.

normal white-on-black text

Any help appreciated!

EDIT: resetting the preferences didn't solve the problem.

| improve this question | | | | |
0

This seems to have been caused by a problem in the incoming iTT file. I was able to solve it by creating a new SRT caption role, selecting all the captions, moving them to the SRT role, and then moving them back. Alternately, it looks like you can change the caption color to something other than white, and then change it back to white. More at https://discussions.apple.com/thread/250624181?answerId=251201017022&page=1.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.