I've got a problem with trying to key the green color with some footage I shot with a Sony FS5. The main object in the frame has some kind of white/light grey border around it which makes it very hard to separate it from the green screen background. Here are some examples:

Original footage...original footage

Trying to key with Keylight in After effects...trying to key with Keylight in After Effects

I shot in 1920x1080, 50 fps 4.2.2 with the internal AVC codec. I think it could be caused by the in-camera sharpening settings, I tried to change the settings but I didn't notice any change.

Each channel isolated (RGB) not keyed:

Red channel Green channel Blue channel

  • 1
    You mention that you changed the sharpening settings. What exactly did you do, and how did you asses the change? The sort of halo that is extremely visible in the R channel looks a lot like some sort of a sharpening filter, not like a 4:2:2 subsampling issue. They may be additional settings you need to fiddle with in the camera to tone this down.
    – wrosecrans
    Jun 23, 2020 at 22:29

3 Answers 3


Have you tried tweaking the settings in Keylight? It looks like the screen replace colour you are using is too light for the black background.

Keylight is a great plugin, and in a perfect world give you one-click keying. But in the real world you usually need to tweak it a bit. The first stop is to check the screen gain and screen balance settings. These look ok for your example, but what you might need to look at is the Screen Replace Color setting.

This setting allows you to pick which colour will be used to replace the screen colour in any pixels that are partially transparent. So on the edges, there are pixels that are partially green and partially foreground colour. To prevent green fringes, once the green has been extracted another colour is put in. By default I think it is mid grey, which presumes that your new background averages out to mid grey. On a black background it shows up clearly. Change the Screen Replace Color to black and that should fix the fringes.

A guide to what the settings do is available at the keylight page.

  • Thank you for the answer. I tried but it didn't fix the problem. I think it's some flaw in the footage itself, maybe because of chroma subsampling. I'll post a reference for each color channel in the original post.
    – Bob
    Sep 11, 2019 at 13:33
  • Chroma subsampling usually leads to blockiness in keys, because the chroma is at a lower resolution than the Luma. That's not really what I'm seeing in the examples. The fringe looks pretty smooth. It could be from ringing in the camera. You could try turning the screen gain up maybe. The green channel looks like it should give you a solid key.
    – stib
    Sep 12, 2019 at 6:11

The other answer is correct that 4:4:4 gives better green screen results. But given that you need to fix your footage, can I recommend both of these tutorials

The most important takeaways from these in my opionion are:

Use the Status setting of the Keylight plugin with a secondary monitor of your footage, so that you can ink-drop precisely the best colour of green to key.

Adjust the black and white points of your matte whilst looking at the Status output.

Use Keylight's Intermediate mode with the Key Cleaner and Advanced Spill suppressor. It gives great results but takes longer to render.


In regards to the green and black mixing, 4:2:2 means pixels are merged and this will always happen, this is why movies shoot in 4:4:4 because then there is no merging of colors. But I have no idea why you are getting a white halo around a black object with a black background.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.