1

I have several long video files that I need to edit (remove some initial parts, breaks and dead moments) and I always got errors when I try to save / export the edited file in mp4. The

pcm_f32le: codec not currently supported in container mp4

message shows when I try to save the edited file in VirtualDub2 (the original file was converted from wmv by VirtualDub2). I can edit an avi file (with 4:26 minutes and 914 Mb) but the edited avi is bigger (3:22 minutes and 2.3 Gb).

I have several Webex sessions (each with 4 – 5 hours) in arf and wmv format (I export using cisco Network Recording Player application).

The WMV files have the ASF (Active Streaming Format) container format, video 1440×768, 25 fps wmv3 video codec, yuv420p, 1000 Kb/sec bitrate. The audio is in stereo s16p, 44.100 Hz, 1152 kb/sec bitrate.

I also can convert the files with VirtualDub2 to mpg4 or Xvid minconverter to avi.

If I use VirtualDub2, the mp4 have the QuickTime/Mov container format, video 1440×768, with h264 video codec, 2.29 fps average, yuv420p (709) and the aac audio codec, stereo fltp, 33 kHz, 50 kb/sec bitrate.

If I use Xvid, the avi (Audio Video Interleaved) container have video 1440×768, mpeg4 video codec, yuv420p, 5 fps and mp3 audio, stereo s16p, 44.100 Hz, 128 kb/sec bitrate.

The unedited video export sizes are similar:

304 Mb arf is converted in a 801 Mb wmv that is compressed into a 509 mb avi or a 506 mb mp4 file.

What is wrong? What settings / log files should i preset/check/validate?

1
  • I am using windows 10 64 bits Sep 4, 2019 at 13:30

2 Answers 2

2

Issue is with the audio track, which needs to be converted/compressed.

See

https://sourceforge.net/p/vdfiltermod/tickets/162/

for steps on how to avoid this issue.

2
0

For me, the solution was exactly as mentioned in the link in the second answer, all kudos to that site. I'll put the answer here explicitly to make sure it won't be lost:

You get pcm_f32 [error] because source audio is decoded in raw pcm (float). To save audio in mp4 you need to select compatible compression:

  1. select Audio->Full processing mode
  2. select Audio->Compression->FFMpeg AAC or FFMpeg Lame MP3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.