I'm having an issue with the latest version of Premiere Pro (v13.1). I am trying to watch a 6-second video but the video does not play in the program panel. When I try rendering in to out, it takes a little longer than 3 minutes to render. After rending, I can view the video normally.

This is my first time using Premiere Pro in a long time but I have not had this issue in the past on this PC. I tried installing it on my laptop and added the same video in sequence and it works like it's supposed to. I can scrub normally and render in to out takes a couple of seconds.

I tried reinstalling the current version of Premiere Pro on my desktop but I still have the same issues. Both my laptop and desktop have the default settings for Premiere and I did not change anything after reinstalling fresh on both devices. In task manager, Premiere uses only 10% of my CPU and under GPU I see that it jumps between 0-10% GPU usage with the used GPU Engine column saying that it's not using any Pu except occasionally for decoding, but only for half a second here and there. I'm not sure if that information helps for I am using Mercury CUDA as my Playback Engine. Again the default settings. Also, both devices use SSDs.

Note that both my desktop and laptop have fresh installs of Premier Pro.

Desktop specs:
Intel i7 8th gen
RTX 2070
GTX 1070  

Laptop Specs:
Intel i7 9th gen
16 GB RAM GTX 1660ti

  • Enter settings and fiddle with graphics settings a little bit? I remember after effects having ray tracing settings. Jun 24, 2019 at 21:06
  • What is in the six seconds?
    – stib
    Jun 25, 2019 at 1:56

1 Answer 1


I managed to figure out my problem. I decided to try disabling my video adapters to see if that fixed my problem thinking that there was an issue with having two dedicated GPUs. I found no problem with having two GPUs but I discovered that disabling Intel graphics on my 8th gen i7 instantly fixed my problem. I'm not sure why that was causing an issue but disabling Intel UHD 630 graphics fixes the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.