1

Help I always get this I dont know why![Picture of the Problem]1

  • Your file is in E:\ffmpeg\bin. So, after opening command prompt. Type E: Press <Enter>, then type cd \ffmpeg\bin, then use your command. – Gyan Jun 18 '19 at 19:00
2

Instead of

-i "video.av"i

use

-i "video.avi"

or simply

-i video.avi
| improve this answer | |
  • 1
    God spot there on the typo :-) – Dr Mayhem Jun 19 '19 at 20:19
1

To be fair, this isn't actually anything to do with ffmpeg. You're using Windows cmd incorrectly. When you call up another executable in cmd, you have tell Windows where to find it. One way is by navigating to the correct folder in cmd before you run the commands. That would be the cd command that changes the working folder. The other way is to map the folder in the system paths, so that you can be in any working folder to use the executable.

In addition to your typo fixes, I strongly recommend mapping a system path to your ffmpeg bin. In other words, actually install ffmpeg. This will allow you to run ffmpeg commands from any working folder displayed in cmd. But your commands will still have to point to the correct folders and files. The only reason I wouldn't bother installing ffmpeg as instructed below is if I'm only temporarily using the system to run a few commands. If I know I'm likely to run future ffmpeg commands on that system, I take the extra few minutes to map the system path and install it.

From How do I set up and use ffmpeg in Windows?

  1. Before you can use ffmpeg.exe in cmd you have to tell your computer where it can find it. You need to add a new system path. First, right click This PC (Windows 10) or Computer (Windows 7) then click Properties > Advanced System Settings > Advanced tab > Environment Variables.
  2. In the Environment Variables window, click the "Path" row under the "Variable" column, then click Edit Steps to add a System path to Windows
  3. The "Edit environment variable" window looks different for Windows 10 and 7. In Windows 10 click New then paste the path to the folder that you created earlier where ffmpeg.exe is saved. For this example, that is C:\Program Files\ffmpeg\bin\ Add new system path Windows 10] In Windows 7 all the variables are listed in a single string, separated by a semicolon. Simply go the the end of the string, type a semicolon (;), then paste in the path. Add new system path Windows 7
  4. Click Ok on all the windows we just opened up.

ffmpeg is now "installed". The Command Prompt will now recognize ffmpeg commands and will attempt to run them.

| improve this answer | |
  • what has path got to do with anything. He is able to run ffmpeg – barlop Mar 19 at 0:27
  • @barlop This answer's not only for the OP, whose error was apparently only a typo. New command line users get a similar message for a different reason that this answer solves. – user24601 Mar 19 at 0:53
  • Just look at the question he asked. The OP's question shows ffmpeg running, you are not answering the question he asked. If you want to answer a different question of A) ffmpeg isn't running and B) They get the different error of "'sdfs' is not recognized as an internal or external command, operable program or batch file." Then your answer would perhaps apply. Right now your "answer", or the bulk of it, is for a different question and a different error – barlop Mar 19 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.