I'm not a pro when it comes to Premiere Pro and just wanted to cut a training video for my job (without bigger animations or something like this).

The finished video is displayed correctly in the preview. But as soon as I export it, or create a new partial sequence from the whole video, the following happens:

The individual clips move in their cutting, or in other words — at some points a few frames are removed at the front, and at the back a few additional frames are shown (the length etc. remains the same). This of course shifts the whole sound and I can see frames in the video that should not be visible.

  • I think you need to add a bit more info: what frame rate and format are the files you're bringing in? add a screen shot of the sequence settings, and tell us what frame rate and format the files are that you're exporting.
    – tomh
    Jul 1, 2019 at 8:08

2 Answers 2


I don't use Premiere Pro, so I don't provide the step-by-step instruction, but I know the basis of your problem.

In your original (compressed) video they are so-called intra-frames (aka keyframes), which contains the full info about the particular frame, and other frames (inter-frames) which contain — simply said — only differences from the previous intra-frames.

enter image description here

In other words:

  • every intra-frame is independent of others frames, while
  • non-intra-frames are dependent on the nearest previous intra-frame
    (and — maybe — from other frames, too).

Let suppose there is 1 intra-frame every 10 seconds (i.e. at time stamps 0 s, 10 s, 20 s, etc.),
and the “other” frames are between them.

Now, you want to cut the 20 s video from the time 13 s (i.e. the range 13 s – 33 s).

The frame at the position 13 s is not an intra-frame — it needs the previous intra-frame (at position 10 s) to obtain the full picture.

So your software simply adds the 3 s part from 10 s in front of your request, and cuts-off the last 3 seconds. The result will be a clip in the range 10 s — 30 s.

But the situation is not so desperate. You have to force Adobe Premiere Pro to re-encode the 13 – 33 s part of original video, i.e. to first compute the frame at position 13 s, then mark it as intra-frame, and make subsequent frames dependent of this new intra-frame.


As I told, I don't know the exact answer. But you have to avoid enabling properties as “Direct Copy”, “Fast Copy”, “Without Re-encoding”, etc.


Change your export setting and use the "frame sampling" option.

  • Thanks for your comment, unfortunately I used it already and it isn't working...
    – orac
    Jun 3, 2019 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.