0

I'm digitizing my old tape recordings from usb dongle. Everything been ok, I digitized several tapes, but I'm abandoned this project for a while and reinstalled windows. Keeping on secondary drive the same ffmpeg binaries and noted .txt file with recording options.

Now I tried to return to work, but in attempts to start recording ffmpeg just finishing immediately:

D:\video>ffmpeg -f dshow -crossbar_video_input_pin_number 2 -video_size 720x576
-rtbufsize 2G -framerate 25 -pixel_format yuyv422 -i video="AVerMedia USB Polari
s Analog Capture":audio="Analog Audio In (AVerMedia C039" -copyts -c:v rawvideo
-c:a pcm_s16le -t 06:00 019.avi
ffmpeg version N-91930-g0caa33c60b Copyright (c) 2000-2018 the FFmpeg developers

  built with gcc 8.2.1 (GCC) 20180813
  configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfi
g --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-lib
freetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amr
wb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --
enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-l
ibwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --
enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --en
able-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --en
able-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --e
nable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enab
le-avisynth
  libavutil      56. 19.101 / 56. 19.101
  libavcodec     58. 30.100 / 58. 30.100
  libavformat    58. 18.100 / 58. 18.100
  libavdevice    58.  4.103 / 58.  4.103
  libavfilter     7. 29.100 /  7. 29.100
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
Guessed Channel Layout for Input Stream #0.1 : stereo
Input #0, dshow, from 'video=AVerMedia USB Polaris Analog Capture:audio=Analog A
udio In (AVerMedia C039':
  Duration: N/A, start: 27907.394000, bitrate: N/A
    Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 720x576, 25 fps,
25 tbr, 10000k tbn, 10000k tbc
    Stream #0:1: Audio: pcm_s16le, 44100 Hz, stereo, s16, 1411 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (rawvideo (native) -> rawvideo (native))
  Stream #0:1 -> #0:1 (pcm_s16le (native) -> pcm_s16le (native))
Press [q] to stop, [?] for help
Output #0, avi, to '019.avi':
  Metadata:
    ISFT            : Lavf58.18.100
    Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 720x576, q=2-31,
165888 kb/s, 25 fps, 25 tbn, 25 tbc
    Metadata:
      encoder         : Lavc58.30.100 rawvideo
    Stream #0:1: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16
, 1411 kb/s
    Metadata:
      encoder         : Lavc58.30.100 pcm_s16le
frame=    0 fps=0.0 q=0.0 size=      10kB time=07:45:07.80 bitrate=   0.0kbits/s
frame=    0 fps=0.0 q=0.0 Lsize=      96kB time=07:45:07.80 bitrate=   0.0kbits/
s speed=4.09e+04x
video:0kB audio:86kB subtitle:0kB other streams:0kB global headers:0kB muxing ov
erhead: 11.267573%

D:\video>

But ffplay playing stream properly and I can watch it

D:\video>ffplay -hide_banner -f dshow -crossbar_video_input_pin_number 2 -video_
size 720x576 -rtbufsize 2G -framerate 25 -pixel_format yuyv422 -i video="AVerMed
ia USB Polaris Analog Capture":audio="Analog Audio In (AVerMedia C039"
Input #0, dshow, from 'video=AVerMedia USB Polaris Analog Capture:audio=Analog A
udio In (AVerMedia C039':
  Duration: N/A, start: 27057.813000, bitrate: N/A
    Stream #0:0: Video: rawvideo (YUY2 / 0x32595559), yuyv422, 720x576, 25 fps,
25 tbr, 10000k tbn, 10000k tbc
    Stream #0:1: Audio: pcm_s16le, 44100 Hz, 2 channels, s16, 1411 kb/s
27060.50 A-V:  0.010 fd=   0 aq=    0KB vq=12961KB sq=    0B f=0/0

I'm stuck and have no idea what can it be. Please help.

P.S. Sorry for my bad english.

2 Answers 2

1

Either remove the -copyts or switch -t 06:00 to -vframes 9000

2
0

This command line work for me:

ffplay -f dshow -video_size 720x480 -framerate 29.97 -i video="Conexant Polaris Video Capture":audio="Conexant Polaris Video Capture"

before testing any command line, identify the name of your capture card in the operating system with the line below:

ffmpeg -list_devices true -f dshow -i dummy

after that, see what resolutions are supported and the frame rate:

ffmpeg -f dshow -list_options true -i video="Conexant Polaris Video Capture"

When listing the capture options for my card, I realized that when it uses 29.97 frame rate it doesn't support 720x576 resolution, but 720x480.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.