1

I’ve discovered some corrupt frames in the footage I am working on (.mxf format, shot on Sony PXW 70, I only have access to the files copied to the hard drive, and the broken frames are in the unedited files). I’ve checked the file with ffmpeg -v error -i (“[h264 @ 0x7fedd70abe00] error while decoding MB 15 37, bytestream -5”) and tried to repair it with ffmpeg -y -i. Not an experienced user though, so unsurprisingly that didn’t work, same broken frame in the same place in the output file.

Here’s the frame itself: https://i.imgur.com/1TrywpA.jpg

So, I guess my questions are: What might be the cause of that? Is there a way to fix it/avoid it in the future?

Would be super thankful for any advice (googling hints included).

4
  • Compression error, possibly due to camera overheating or some defect/bug in the camera. Transcode it once with ffmpeg -threads:v 1 -enable_er true -i ... and check. – Gyan Feb 25 '19 at 5:31
  • @Gyan, thanks a lot. Tried it, toharsky$ /Volumes/FFmpeg\ 4.1.1/ffmpeg -threads:v 1 -enable_er true -i /Volumes/Macintosh\ HD/Users/toharsky/Downloads/Clip0048.MXF output.MXF but seem to be getting another mistake now: Unrecognized option 'i /Volumes/Macintosh HD/Users/toharsky/Downloads/Clip0048.MXF'. Error splitting the argument list: Option not found What am I doing wrong? the problem is not the path, it's recognised when I do /Volumes/FFmpeg\ 4.1.1/ffmpeg -v error -i /Volumes/Macintosh\ HD/Users/toharsky/Downloads/Clip0048.MXF -f null - &> corruptions.log – toharsky Feb 26 '19 at 22:55
  • Add -report and run. Share report. – Gyan Feb 27 '19 at 4:39
  • @Gyan, thanks again. I was able to run it now, no clue what was the problem. Here's the log. The corrupt frame is still there after transcoding. – toharsky Feb 27 '19 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.