1

This might be an easy question, but I'm not able to find the answer. Sometimes the audio clip is slightly small than the video clip. I need to move the audio just a little bit (like less than 1 second), however final cut moves it to the opposite border straight away.

2

It looks like Snapping is turn on. Toggle it with N or use the snapping icon (next to clip view options and transitions etc).

enter image description here

1

Zoom in for more precise placements and turn snapping off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.