0

I'm trying to improve some VHS-C home video recordings for my mother. I used VirtualDub to capture the recordings as avi files and now I wish to modify them with Avisynth but I can't get the frame server function to work. Has anyone got the VirtualDub frame server connection with Avisynth working in Windows 10?

I've tried this with the latest versions of VirtualDub, Avisynth, and both AvsP_v2.0.2 with bugfix3 and AvsPmod. Also, I've tried it with VirtualDub_1910.exe, Avisynth_258.exe, AVSPluginPack.exe and AvsPmod_205.exe from AnimeMusicVideos.org (AMVapp31.zip). I'm using Windows 10 64-bit however I've only downloaded 32-bit version software and codecs because that seems to be the generally recommended route. (Is the AVSPluginPack necessary? If so, is there somewhere other than AMV that maintains it?)

In VirtualDub, I open homevideo.avi, "Crop to selection" for a desired range of frames and then File > Start frame server... and name the Avi-File Handler video.vdr.

In AvsP and AvsPmod the commands:

video = AVISource("c:\VHSC\video.avs")
return video

where video.avs is a file that contains only the line AviSource("c:\VHSC\video.vdr")

produce the error message:

Avisynth open failure:AVIFileSource: couldn't open file 'c:\VHSC\video.vdr'
(C:\VHSC\video.avs, line 1)
(New File, line 1)

However, replacing video.avs with homevideo.avi does display the frames in the AvsP/mod window.

I've seen this similar question AviSynth can't open my AVI file: "AVISource: Couldn't locate a decompressor for fourcc dvds". The virtualdub website < http://www.virtualdub.org/docs_frameserver.html > says "Use the AVISource filter. DirectShowSource is unreliable". I've tried both.

To capture the VHS tapes in VirtualDub I followed a YouTube tutorial, which involved the following steps:

Downloaded and install Virtual Dub + Lagarith codec
File > Capture AVI
File > Set capture file[name]
Device > [chose my capture device]
Video > Video source > [chose the source]
Video > Capture filter > PAL_B
Video > Compression > Lagarith
-then in Configure > [mode=]YUY2;
-Checking both Use Multithreading and Prevent Upsampling When Decoding.
Video > Set custom format -- settings: 820 576 YUY2*
(*actually set as UYVY [the default setting] because YUY2 is not compatible with my capture device)
Capture > Settings > 25.0
At the bottom of the capture window -- selected 44.10 kHz, 16 bit, Stereo
Start: Capture > Capture video
End: Capture > Stop capture
0

Did you install the frameserver support with auxsetup.exe? You can test if it is working by trying to open your video.vdr with another instance of virtualdub.exe.

From your description it doesn't look you really need the frameserver. You can trim the video with avs itself (e.g. Trim(100,200)), this is more robust and efficient.

Btw did you know there is active avisynth community on forum.doom9.org, forum.videohelp.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.