I have tried using both VSDC and VideoPad for editing videos, and both of them randomly darken the videos I put into them. Is this a common issue? If not, what information do you need me to give to solve this problem?

This is a problem I have had on multiple computers now.

Here are some side-by-side comparisons, with each pair being first the input video and then second the output video.

enter image description here

enter image description here

You can see that this second image is darker.

enter image description here

enter image description here

You can see that this second image is darker also.

Edit: I tried editing the video with FFmpeg, and it did the same thing.

Edit 2: Here are the outputs of ffmpeg -i [videofile]:

Original video:

    encoder         : Lavf58.12.100
Duration: 00:01:32.75, start: 0.000000, bitrate: 1012233 kb/s
    Stream #0:0: Video: huffyuv (HFYU / 0x55594648), bgr0, 1920x1080, 1012406 kb/s, 60 fps, 60 tbr, 60 tbn, 60 tbc

Edited video:

Duration: 00:01:36.98, start: 0.000000, bitrate: 514031 kb/s
    Stream #0:0: Video: mjpeg (MJPG / 0x47504A4D), yuvj422p(pc, bt470bg/unknown/unknown), 1920x1080, 512695 kb/s, 59.99 fps, 59.99 tbr, 59.99 tbn, 59.99 tbc
    Stream #0:1: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16, 1411 kb/s

Edit 3: The original video was compiled from a series of .png files. Here is the command I used to do so:

ffmpeg -framerate 60 -i %05d.png -c:v huffyuv -pix_fmt rgb24 output.avi
  • Share the console output of ffmpeg -i videofile
    – Gyan
    Oct 26, 2018 at 13:27
  • @Gyan I added part of the console outputs. Are they what you were looking for? If not, should I post the full output? All I removed was all of the --enable arguments and the versions of FFmpeg's various libraries. Nov 4, 2018 at 19:03
  • How were the source videos generated/captured - which app and settings?
    – Gyan
    Nov 5, 2018 at 12:50
  • @Gyan It was a series of .png files compiled as frames into a video using FFmpeg. I added the command I used to my question. Nov 16, 2018 at 7:54


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.