0

I have a video file from my Hikvision NVR which I cannot play on Windows 10 in either VLC or Windows Media Player - all I get is a black video and the seek bar just whizzes along...

I can play this video in VLC on Windows 7 so I'm pretty sure it has something to do with the fact that it is a new computer.

Media Info gives me the following:

Complete name               : C:\Users\cos\Web\PlaybackFiles\2018-07-18\192.168.1.250_02_20180718224704172.mp4
Format                      : MPEG-PS
File size                   : 3.40 MiB
Duration                    : 1 min 51 s
Overall bit rate            : 257 kb/s
FileExtension_Invalid       : mpeg mpg m2p vob pss evo

Video
ID                          : 224 (0xE0)
Format                      : AVC
Format/Info                 : Advanced Video Codec
Format profile              : Main@L5
Format settings             : CABAC / 2 Ref Frames
Format settings, CABAC      : Yes
Format settings, ReFrames   : 2 frames
Duration                    : 1 min 51 s
Width                       : 2 560 pixels
Height                      : 1 440 pixels
Display aspect ratio        : 16:9
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : Progressive
Color range                 : Full
Color primaries             : BT.709
Transfer characteristics    : BT.709
Matrix coefficients         : BT.709

Audio
ID                          : 192 (0xC0)
Format                      : MPEG Audio
Duration                    : 1 min 51 s
Compression mode            : Lossy
Delay relative to video     : -5 min 7 s

Text
ID                          : 189 (0xBD)
Format                      : RLE
Format/Info                 : Run-length encoding
Duration                    : 1 min 41 s

I'm sure this is a codec, or perhaps lack of codec, issue but I need some help to determine what the cause of the issue is.

Has anyone experienced thisbefore?

  • It's not a codec issue, per se. Rename extension to .mpg or .vob and check. Else, remux using ffmpeg: ffmpeg -i in.mp4 -c copy out.mp4 – Gyan Jul 20 '18 at 5:38
  • @Gyan tried renaming and I still get the same results. Annyoing that I suddenly lost this ability by upgrading to a different OS!! – cosmarchy Jul 20 '18 at 19:16
-1

There is hardly any video in your AVC file. The data rate is 0.2Mb and the frame is a full size PC desktop resolution (WQHD) instead of a "real" video resolution such as 1920x1080. Based on its size, I'd guess you only have 2 frames in there. That would be stretching a bit if you need a real video file. A low bandwidth (25Mb) AVC source of this size would be 100x bigger.

Try using a standard HD res at the source, a bigger bitrate and more key frames.

|improve this answer|||||
  • Why do you say that 25 Mbps is a "low bandwidth" for AVC? That's very high, I'd say – mcont Aug 20 '18 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.