I can watch videos on a website with MPEG-DASH technology.

I can obtain the video's manifest.mpd file from the website. (I am not sure whether the file contains any user credentials or not, so I am not going to post it)

The video contains 3 tracks (1 video track + 2 audio tracks), and I found 3 <AdaptationSet/> elements with attribute mimeType in manifest.mpd.

They both contain a <SegmentTemplate/> element which has an attribute media containing the segment filename template which is being used to download the segment files in the browser from time to time.

The values to be used to construct the segment file URL are inside SegmentTemplate.SegmentTimeline.S elements.

For example :

<AdaptationSet mimeType="video/mp4" ...other attributes>
      <S t="0" d="900000"/>
      <S d="900000" r="352"/>
      <S d="638370"/>
  <Representation id="SOME-ID" codecs="avc1.640029" sar="1:1" bandwidth="1268094"/>
<AdaptationSet mimeType="audio/mp4" ...other attributes>

will produce requests to


some-website-domain/some-path is not sure at this moment, but I could figure this out.

The real question is:

Is it possible to download and encode all the segment files into one single video file?

---- EDIT ----

After running the following command:

ffmpeg -v 48 -i manifest.mpd -c copy out.mp4

I got this output:

Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '48'.
Reading option '-i' ... matched as input url with argument 'manifest.mpd'.
Reading option '-c' ... matched as option 'c' (codec name) with argument 'copy'.
Reading option 'out.mp4' ... matched as output url.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 48.
Successfully parsed a group of options.
Parsing a group of options: input url manifest.mpd.
Successfully parsed a group of options.
Opening an input file: manifest.mpd.
[NULL @ 0x7feff2000800] Opening 'manifest.mpd' for reading
[file @ 0x7feff1c0b100] Setting default whitelist 'file,crypto'
[AVIOContext @ 0x7feff1c0b2c0] Statistics: 28989 bytes read, 0 seeks
manifest.mpd: Invalid data found when processing input
  • 1
    Should be as simple as ffmpeg -i in.mpd -c copy out.mp4. The dash demuxer will fetch the segments and demux in order.
    – Gyan
    Jul 9, 2018 at 13:24
  • Tried with ffmpeg 3.4.1, but got manifest.mpd: Invalid data found when processing input
    – kit
    Jul 9, 2018 at 13:38
  • I guess some data in the MPD is not in standard format, so ffmpeg could not construct the segment filename, for example, ffmpeg may not know id of <Representation/> is related to media of <SegmentTemplate/>.
    – kit
    Jul 9, 2018 at 13:42
  • 1
    Try with the latest version. There have been a number of bugs fixed over the last few months.
    – Gyan
    Jul 9, 2018 at 14:15
  • Updated to ffmpeg 4.0.1, still the same error
    – kit
    Jul 9, 2018 at 14:47

5 Answers 5


Regarding your FFMPEG issue, you need to build/obtain FFmpeg with --enable-libxml2 configuration enabled to correctly parse a manifest.mpd file.

You can check whether your FFmpeg supports libxml2 by simply running it without any arguments. Here is the output from FFmpeg 4.1 I built with --enable-libxml2 (see --enable-libxml2 in the start of the 4th line of the output):


ffmpeg version n4.1-10-g59e30c05d7 Copyright (c) 2000-2018 the FFmpeg developers   
built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.6) 20160609
 configuration: --enable-gpl --enable-version3 --enable-openssl 
--enable-libxml2 --enable-libssh --enable-libvorbis --enable-libvpx 
--enable-libwavpack --enable-libwebp --enable-libx264 
--enable-libx265 --enable-libxvid --enable-libzmq 
--enable-libzvbi --enable-libopus --enable-libpulse --enable-gmp --enable-libmodplug --enable-nonfree
          libavutil      56. 22.100 / 56. 22.100
          libavcodec     58. 35.100 / 58. 35.100
          libavformat    58. 20.100 / 58. 20.100
          libavdevice    58.  5.100 / 58.  5.100
          libavfilter     7. 40.101 /  7. 40.101
          libswscale      5.  3.100 /  5.  3.100
          libswresample   3.  3.100 /  3.  3.100
          libpostproc    55.  3.100 / 55.  3.100
        Hyper fast Audio and Video encoder

Regarding your question above, once you have a working FFmpeg with --enable-libxml2, you can transcode the .mpd to .mp4:

ffmpeg -i manifest.mpd -codec copy out.mp4

Note: I use -codec copy above to avoid transcoding of actual video and audio.

  • 2
    I can see I have --enable-libxml2 but there are still errors when I try on a downloaded mpd file: [dash @ 0x564eaaa95740] Filename extension of 'dash/e10f30c1-485c-4f2f-8d62-403cde8d4c10_monde_TA-video=400000.dash' is not a common multimedia extension, blocked for security reasons. If you wish to override this adjust allowed_extensions, you can set it to 'ALL' to allow all But -allowed_extensions ALL produces errors also. With youtube-dl it worked on the mpd URL (ffmpeg got 403 Forbidden).
    – baptx
    May 29, 2021 at 22:11

Easy youtube-dl example on macOS (in the command line Terminal; Windows supported too):

$ youtube-dl -F https://bitdash-a.akamaihd.net/content/MI201109210084_1/m3u8s/f08e80da-bf1d-4e3d-8899-f0f6155f6efa.m3u8
[generic] f08e80da-bf1d-4e3d-8899-f0f6155f6efa: Requesting header
[generic] f08e80da-bf1d-4e3d-8899-f0f6155f6efa: Downloading m3u8 information
[info] Available formats for f08e80da-bf1d-4e3d-8899-f0f6155f6efa:
format code           extension  resolution note
audio-English_stereo  mp4        audio only [en] 
628                   mp4        320x180     628k , avc1.42c00d, video only
928                   mp4        480x270     928k , avc1.42c00d, video only
1728                  mp4        640x360    1728k , avc1.42c00d, video only
2528                  mp4        960x540    2528k , avc1.42c00d, video only
4928                  mp4        1280x720   4928k , avc1.42c00d, video only
9728                  mp4        1920x1080  9728k , avc1.42c00d, video only (best)

$ youtube-dl --format 628 https://bitdash-a.akamaihd.net/content/MI201109210084_1/m3u8s/f08e80da-bf1d-4e3d-8899-f0f6155f6efa.m3u8
frame= 5257 fps=193 q=-1.0 Lsize=    6746kB time=00:03:30.16 bitrate= 263.0kbits/s speed=7.73x    
video:6679kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.998669%
[ffmpeg] Downloaded 6907810 bytes
[download] 100% of 6.59MiB in 00:29

$ open f08e80da-bf1d-4e3d-8899-f0f6155f6efa-f08e80da-bf1d-4e3d-8899-f0f6155f6efa.mp4

Use the browser's Developer Tools > Network to get the mpd/m3u8 (DASH/HLS manifest) URL when starting a streaming video.

  • works like a charm Jun 26, 2019 at 22:43

In addition to ffmpeg and youtube-dl/yt-dlp mentioned upthread, you can try

Only dash-mpd-cli will work with DRM-encrypted content (assuming you have the necessary decryption keys).


ffmpeg -i manifest.mpd -codec copy out.mp4 almost works.

the file that is downloaded is corrupt. Only distorted colors are seen in the downloaded video.


For me the BaseURL wasn't a url it was the file names, so when you ran this

ffmpeg -i DASHPlaylist.mpd -c copy out.mp4

It doesn't know where to get the data from.

enter image description here

So what we can do is add the url of the .mpd file to each BaseURL or use the source of of the .mpd file to run ffmpeg. (edit each .mpd file you download to add the urls to each BaseURL or use the .mpd file from the URL)

enter image description here


ffmpeg -i https://example.com/unique_id/DASHPlaylist.mpd -c copy out.mp4

Which should have the same out.mp4 file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.