1

So the problem is -- I moved .ai file into sub-composition and then zoomed this composition inside of the main composition. And now it's blurry.

I know for the vector files I can choose "Continuously Rasterize", but in my case it's not just a vector layer, it's vector layer inside of the composition.

There is a option called "Collapse Transformations", it helps and makes vector layer nice and smooth, but it ruins the puppet-animation that is inside of the comp.

What should I do?

0

About the only thing to do is scale up the nested comp (the one with the puppet animation in it), so that it matches the size it needs to be in the outer comp without having to zoom it.

There's a script that will do this for you, if you look at the File>Scripts> menu there should be one called scale composition.

This script basically just attaches everything in the comp to a null, resizes the comp using the comp settings, then scales the null to match. So if the script doesn't work for you you can do it manumatically.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.