1

I have an interesting problem:
When I stream to Twitch (or record), my desktop audio goes out of sync with the video over time. The microphone is perfectly synced the whole time.
Both OBS Studio and "playback device->Speakers" have 44.1kHz.
I have device timestamps on, started with it off, changed it because of the desync.
OBS Settings

2

So with everything I've tried I'm not sure if I messed anything up, but....

Turning off "Use device timestamps" in the properties of "desktop audio" fixed the problem.

| improve this answer | |
  • The "Use device timestamps" doesn't show in the latest OBS Studio version, is it there anywhere else? – Rodrigo Polo Feb 19 '19 at 12:03
  • Did you look everywhere ? there's like 3 different menus for audio properties. I don't even remember how to get there... – xyious Feb 19 '19 at 17:10
  • Yes, I did search everywhere, I have posted the same question right now here: obsproject.com/forum/threads/audio-gets-out-of-sync.70179/… – Rodrigo Polo Feb 21 '19 at 0:28
0

Don't know if this will still be useful but the "Use Device Timestamps" checkbox is still in the latest version. Click the cog next to Desktop Audio in your Audio Mixer. It's in there. Having same issue and hoping this helps, thank you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.