0

Let's start off from the beginning: I have already configured KdenLive to point to the melt.exe file, and all the other proper plugins to allow rendering.

When I hit "Render" and try to render to a file, I am told that it has started to render, and then I am instantly told that the render completed successfully, in 00:00:00. However, there's nothing saved to disk.

I tried analyzing the script that generates when you select "Generate Script". It seems to be giving a "usage" dialog due to incorrect parameters. I'm wondering if maybe this is the problem. It reads as follows:

C:\Users\b4ux1\Documents\Vlogs\2017-10-22>"E:/Kdenlive-
17.08.1/kdenlive_render.exe" "in=0 out=100 "E:/Kdenlive-
17.08.1/share/mlt/melt.exe" atsc_1080p_60 avformat - 
"file:///C:/Users/b4ux1/Documents/Vlogs/2017-10-22/2017-10-22_001.bat.mlt" 
"file:///C:/Users/b4ux1/Documents/Vlogs/2017-10-22/2017-10-22.webm" f=webm 
vcodec=libvpx acodec=vorbis crf=15 vb=0 quality=good aq=7 max-intra-
rate=1000 cpu-used=4 threads=4 real_time=-1"
Kdenlive video renderer for MLT.
Usage: kdenlive_render [-erase] [-kuiserver] [-locale:LOCALE] [in=pos] 
[out=pos] [render] [profile] [rendermodule] [player] [src] [dest] [[arg1] 
[arg2] ...]
  -erase: if that parameter is present, src file will be erased at the end
  -kuiserver: if that parameter is present, use KDE job tracker
  -locale:LOCALE : set a locale for rendering. For example, -locale:fr_FR.UTF-8 will use a french locale (comma as numeric separator)
  in=pos: start rendering at frame pos
  out=pos: end rendering at frame pos
  render: path to MLT melt renderer
  profile: the MLT video profile
  rendermodule: the MLT consumer used for rendering, usually it is avformat
  player: path to video player to play when rendering is over, use '-' to disable playing
  src: source file (usually MLT XML)
  dest: destination file
  args: space separated libavformat arguments

Rendering Job Queue showing successful render.

Output folder showing absolutely nothing having been rendered.

0

I was having the same problem. Found this fix from the bug reports. I did it all, exactly as it says, including the part that changes the melt directory in the program as opposed to moving the melt file to match the directory, and it worked. I did not lose my saved project that previously wouldn't render. It's saved in a different location and keeping it did not effect the fix.

https://bugsfiles.kde.org/attachment.cgi?id=108162

| improve this answer | |
  • 1
    Can you describe the steps on the linked page in case it becomes unavailable, please? – Michael Liebman Oct 28 '17 at 22:14
0

Had the same problem and fixed it. Sort of in agreement with Alisha's fix.

Check the Settings-Configure Kdenlive-Environment-MLT environment. Because I had both an installed version and a standalone version on my disk, the automatic setting is pointing to different paths. If the path is not set correctly to point to the ffmpeg, ffplay, ffprobe, mlt, melt, then the software cannot correctly call those exes to perform the render operation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.