2

I'm a physicist with no experience in video production.

I work with satellite imagery and I have created timelapses where one frame corresponds to one minute. It matters I preserve the time/frame rate. However, I am finding this difficult

Using Adobe Premiere Pro I track features on the satellite imagery using a coloured dot (using timeframes etc), then export this as a movie which I analyse using a script I have coded. I then get data regarding where the coloured dots are, their velocity and the interactions between them. However, my velocities are meaningless at the moment because of the frame rate issue - I can't preserve the 1 frame for one minute issue. Sometimes premiere pro skips frames or doesn't update the whole frame, etc.

I cannot get the frames to be preserved though my animation process. I have a counter on the timelapse which increases by 1 for each frame. In the finished video, this no longer increases by 1 for each frame.

I really want to maintain the frame rate and stop "interlacing", i.e. where the whole frame doesn't update. I just want the original video with my animations on them - no other changes.

Edit with examples

The interlacing problem: enter image description here

This frame is repeated twice in the resultant video: enter image description here

Full video (2Mb) can be found here. (https://www.dropbox.com/s/x0dmj9j8br2j4y3/AL_202_Tracking%20copy.mov?dl=0). When going frame by frame, note that the frame counter of the original timelapse at the bottom right hand of the screen does not match that of the resultant video with animation overlay. The solution ideally needs to have each frame of the original timelapse match that of the resultant video. i.e. each time you move forward a frame, the counter increases by an integer.

If anyone is interested what you are looking at; its x-ray imagery from the Hinode satellite (NASA/JAXA) pointing at the sun, looking at eruptions from the sun.

  • It isn't really clear what you are asking here. How is Premiere skipping frames? How do you realize this is occurring? On a rendered video, there is no reason there should be skipped frames unless something is wrong with your playback engine? Do you mean that you are using premiere to do the tracking and it is sometimes losing the track? – AJ Henderson Sep 8 '17 at 13:49
  • Added example. On rendered video, see that the counter does not always increase by one when moving frame by frame. On the original timelapse, this is the case, i.e. each frame increases the counter by 1. Premiere is working fine, apart from exporting in a way which does preserve the frame rate. – Tomi Sep 8 '17 at 14:57
  • What output settings are you using? – AJ Henderson Sep 8 '17 at 15:04
2

At first I did not understand your question, after you have supplied the example video I understood what your problem is.
The issue is that when you import the Images, Premiere Pro assigns a default Frame Rate to them, which might be different from what you desire.
Changing Sequence Frame Rate does not change Images default Frame Rate when you import them, to fix this you can do the following:

  1. Create a new Project
  2. In Project Window right click > import > select first Image only and check Image Sequence. enter image description here

  3. Right click on Image Sequence in Project Window > modify > interpret Footage. enter image description here

  4. check "Assume this frame rate" and set desired FPS and click OK. enter image description here
  5. Drag Image Sequence from Project Window to Timeline. Then Render/Export as usual and make sure the Frame Rate at export matches the one you set up earlier.

NOTE: Image Sequence imported, Sequence in Timeline and Export Settings have to have the same Frame Rate.
That is all. You should not have any Skipped or Extra Frames in output video.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.